Issue with "Active Directory Users and Computers" client, with non Domain administrator

We have an issue with "Active Directory Users and Computers" installed on a users that is not a member of the Administrator, we want her to add contacts only and nothing else, we gave her the proper delegation, and we still get this error "Access is denied, Facility: Win32 ID no: c0070005, Microsoft Active Directory - Exchange Extension", but when we grant her "temporarly" member of the "Domain Admin" it works BUT we dont want that. Is there a bug with SP3 in Exchange 2003? And a easy fix without working on the exchange server itself?
Thank you
S.

exchange-error.bmp
OTNAdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

GeyybeccaCommented:
are you running the whole AD users and computers snap in or have you saved a customer MMC with just the Functions she needs?
0
OTNAdminAuthor Commented:
Hi Geyybecca,
I installed the admin pack which populates the admin tools sections I then installed the exchange management tools which works with the admin pack, No mmc configrued
hope this helps
0
drchristopheCommented:
Hi,

You will need to delegate rights for this user in the Exchange Organisation.

We have created a group called "service desk" with appropriate service desk users in it. Then in Exchange System Manager I delegated this group the Exchange Administrator role.

Here is a link to a step by step guide:

http://support.microsoft.com/kb/823018

Let me know how you get on.......

0
OTNAdminAuthor Commented:
Hi drchristophe, we Created a Group called "Contact creator group" added the user, added that group the role of "Exchange Administrator" in "system manager". Loged user off and back on, went to "AD" shortcut and tryed adding contact, but it seims that it "hangs" now always after trying to input the email adress in the SMTP feild. We dont get the error message anymore but hang. Any clue?
Thank you
0
drchristopheCommented:
Two things may effect this.....

1) Exchange taking time to catch up. I always leave Exchange a good hour before trying changes.

2) Admin tools on pc need uninstall/reinstall. Have you tried on a different pc?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.