Exchange 2007 not sending external Out of Office

Experts-

My Exchange 2007 server is only responding to internal OOO messages.  I've validated that the EMC hub transport shows to allow external emails yet none are sent.  The server uses GFI Mail Essentials to route incoming messages from my ISP via the pop2exchange service to the mailboxes.  I validated that Outlook 2007 has external turned on.  What am I missing?

Thanks,

-Joe
Joe ThompsonPrincipal ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ATIGCommented:
did you enable internal and exteranl oof? This is configurable option with Exchange 2007.

http://msexchangeteam.com/archive/2006/10/06/429115.aspx
0
Joe ThompsonPrincipal ManagerAuthor Commented:
Apologies for the delay.  I went out of town before I had a chance to respond.  My Exchange server was set to allow external out of office messages (3rd selection in the EMC hub transport default properties), so I changed it to allow both internal and external (4th selection).  Neither enabled OOF external messages however.  
0
Joe ThompsonPrincipal ManagerAuthor Commented:
Increasing points as this is still open.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

wallacrIT ManagerCommented:
I have the same problem, I have the third option selected and notice that the out of office reply messages appear in the message trackin logs, but they don't get to the external senders.  Everything works well internally.  I'm guessing it's something to do with coming from exchange 2003, but not sure on that and am still unable to find a solution so far.

Rich
0
Joe ThompsonPrincipal ManagerAuthor Commented:
Apparently no one can find an answer as the lack of response is showing.  :(
0
wallacrIT ManagerCommented:
Ok, I've made a little progess here, it seems that it's something to do with below settings:

Organization Config > Hub Transport > Send Connectors

Usually I sent all out bound emails via an external scanning service.  However, if I change the settings in here to 'Use doman name system (dns) 'MX' records to route mail automatically' then external out of office messages & delivery receipts work.  

If I attempt to route them via a different source again, then they stop working again.

Rich
0
Joe ThompsonPrincipal ManagerAuthor Commented:
I reloaded my Exchange server and now it works, so unsure what the real issue ever was.
0
NexusosCommented:
I too have this problem on two seperate Exchange 2007 setups - external OOF only works if mail is configured to deliver direct.

This is not ideal though - did either of you find a solution to this? Rollup3 didn't fix it....
0
wallacrIT ManagerCommented:
No, unfortunately I still have the problem so have reverted to sending directly, but I agree that this is far from ideal.

Hopefully someone will find a fix soon.
0
Joe ThompsonPrincipal ManagerAuthor Commented:
I use GFI pop2exchange so not delivered directly.  Yet, my OOO external worked after reloading the server.  Sorry I can't be more accurate.
0
wallacrIT ManagerCommented:
I did contemplate reloading my exchange server, but unfortunately I can't really afford the downtime on it so decided against it :(
0
NexusosCommented:
Ok, I've finally gotten to the bottom of what's going on.

This is all related to a change that Microsoft has made to Exchange 2007's OOF & NDR responses. Essentially, previous versions of Exchange did not follow RFC 2298 guidelines for Message Disposition Notification (MDN) messages and therefore responded with an email address in the FROM: field, which doesnt actually follow the correct definitions for this type of SMTP response. The latest version of Exchange now strictly follows RFC 2298 definitions for MDN messages.

The reason that this is an issue is because a blank sender field is often used by spammers to distribute unsolicited mail and is therefore blocked by default by many anti-spam systems. Anti-spam systems such as this are deployed at most major ISPs to avoid their mail relays being abused by users or compromised systems on their network, hence my customer's ISP were actually blocking their MDN messages (even though they appeared to accept them without issue).

As this is a feature of Exchange 2007 and not a configurable option, I have circumvented the issue by configuring my customer's mail systems to deliver direct instead of sending mail through their ISP's SMTP gateway.

In order to ensure that their outbound mail relay is seen as a trusted non-spam source I have had to make the following changes before enabling direct delivery;

" Created a reverse DNS PTR record for their external IP address that resolves to the same as the forward lookup for that address
" Reconfigured the SMTP service so that the SMTP response comes from the public FQDN instead of the servers local FQDN
" Created an SPF record in their public DNS that authorises the external IP address of their internet connection to send mail from their external domain

Once the above changes have been made and enought time has passed to ensure DNS replication, it is safe to enable direct delivery of SMTP traffic.

It is worth mentioning that although external OOF messages are now working, OOF responses may still not be received by any organisation that uses an anti-spam system that blocks emails with blank senders. All regular external mail will flow as expected  this issue will only affect MDNs. While not ideal, this is at least preferable to no MDN responses.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joe ThompsonPrincipal ManagerAuthor Commented:
Since my server reload fixed this issue, awarding points to Nexusos for continued complete responses.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.