[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1376
  • Last Modified:

Unable to Push Client installs with SMS 2003

Please excuse the length of my post but I've done alot of troubleshooting and just want to be thorough. I'm almost to me wits end! {:o)

Software:
SMS 2003 installed on Windows Server 2003 SP2

History:
Back in August of '07 our SMS server crashed (hardware issue...not software).
I was able to rebuild it and get everything back online. It does have a new IP address than the original server did. All my clients reported back in and I can use remote tools with them. Since then (November and December of '07) I successfully pushed clients to new computers we installed at new locations and everything has been dandy.

Problem:
For the past couple of days I have been trying to push clients to new computers in the field with no success. When I look in the CCM.log I get the the error "Warning: no remote client installation or SMS service account found". It also can't access the admin$. Here is a snippet of the log:

======>Begin Processing request: "OETSOERY", machine name: "HENTRN001734"      SMS_CLIENT_CONFIG_MANAGER      2/8/2008 2:45:46 PM      6080 (0x17C0)
---> Trying each entry in the SMS Client Remote Installation account list      SMS_CLIENT_CONFIG_MANAGER      2/8/2008 2:45:46 PM      6080 (0x17C0)
---> Warning: no remote client installation or SMS service account found      SMS_CLIENT_CONFIG_MANAGER      2/8/2008 2:45:46 PM      6080 (0x17C0)
---> ERROR: Connected to HENTRN001734 registry, but couldn't connect to the \\HENTRN001734\admin$ share using account ''      SMS_CLIENT_CONFIG_MANAGER      2/8/2008 2:45:47 PM      6080 (0x17C0)
---> ERROR: Unable to access target machine for request: "OETSOERY", machine name: "HENTRN001734", error code: 1003      SMS_CLIENT_CONFIG_MANAGER      2/8/2008 2:45:48 PM      6080 (0x17C0)

I should mention that these computers are additions to the current location. I have about 15 computers online and working with SMS and have been for over a year now. This issue is just for the 8 new computers I added. I've also played with a couple of computers and other locations on different subnets and still have the same issue. So I know it isn't a localized issue.

I noticed that the computers already have the client installed on them (I assume this was accidentally left on the image we use for the computers). So I experimented with a couple of things. On one computer I CCMCleaned it and the other I deleted the certificate. Neither worked. Also, on those computers the site was not assigned. When I try to "Discover" it says "Automatic Site Code Discovery Was Unsuccessful".

Steps I Have Taken:
1.) Verified that the service account is in good order (no disabled, password hasn't expired)
2.) Verified the service account is a member of the Enterprise Admin group
3.) Updated WINS to reflect the new ip address for SMS_SLP
4.) While logged into the SMS server as the SMS Service Account, I verified that I am able to navigate to the computers admin$ share.
5.) Verified that the subnets are in Sites and Services

Any ideas? Clues? I've gone through so many different forums that have had some good information but none has solved my issue.
0
lffit
Asked:
lffit
  • 9
  • 6
1 Solution
 
schristeCommented:
Some questions if you don't mind:

1st - Is this SMS SP3 you have installed and if so does the client installed match what is on the server? Possible the client has an older version of the client installed.

2nd - What do the client location logs look like?
Possible those clients are trying to reach out to a different SLP

3rd - These new computers....are they from another domain, do they or have they ever had SMS installed, are they from another site that had SMS?
Possible SLP issue or in correct site code, or Site boundary issue

4th - Does your SMS service account have access as admin on those machines?

5th - What sort of error is CCMclean giving you when you try running that?
0
 
lffitAuthor Commented:
I love questions cause it might lead to a solution! heh heh.

1st - Honestly I don't know what version I'm running. I don't believe it is SP3. That is one thing I haven't been able to find is where the version info is located. How to I get to that?

2nd - Ah HA! I looked at the location services log and there is an error in there stating that it was unable to connect to host=x.x.x.81 (x in their for security purposes). The server IP was changed to .87 after the rebuild. How do I get this updated?

3rd - No, we only have 1 domain. The image I used on these "newer" computers was actually created back before August of last year when I had to rebuild the SMS server. I believe they might have had the client on the image by mistake. That was one of the steps I took earlier was to ccmclean the client off. And also tried removing just the certificate on another.

4th - Yes, the SMS service account is not only an Enterprise Admin but also Domain Admin

5th - No error, it removed the client successfully.
0
 
lffitAuthor Commented:
Sorry, I reread my inital post and noticed something might be misleading.

"On one computer I CCMCleaned it and the other I deleted the certificate. Neither worked."

What I meant is the ccmcleaned and the deletion of the certificate completed successfully...but neither of them solved my problem.
0
[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

 
lffitAuthor Commented:
One more thing, I looked at the location services on one of the computers I can actually remote to (mine) and noticed that it is getting the same error while trying to communicate with the old IP. So I'm guessing whatever I have to do I'll have to do it to all our computers.
0
 
schristeCommented:
You can find the client version that's installed at this reg key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Mobile Client
Should say ProductVersion with a value of 2.50.4253.3000 (That's if you are running the SP3 client) SP2 client will have .2000 at the end of it.

To find your version of SP on the server:
Open your SMS console, right click on the Site Database and choose "About Systems Management Server...."
That will tell you what SP lvl you are at. If you are at SP2 then dl and install SP3.

If you ran the CCmclean, I assume you did that while you had the system in your hands.....can you run the client install with the .msi file? You can modify the .msi to reflect all changes to your SMS site with an application called ORCA. That way it will automate the install for you.

One other free site that I have found to be a great source of information is:
http://www.blogcastrepository.com/blogcasts/folders/sms/default.aspx

Run the CCMclean again and make sure that it removes all traces of the old client then install the newest SP3 client using the client.msi file. Hope that helps. :)
0
 
schristeCommented:
Also, that is the error in your clientlocation log file?
0
 
schristeCommented:
Sorry....that was supposed to read *What is the error in your client location log file.*
0
 
lffitAuthor Commented:
I'm on SP1
I guess I should upgrade then? What does that entail? Once I upgrade do I need to repush all the clients as well? If so, that might lead back to my initial issue where it says it has no service account and can't attach to the admin$.

No "errors" really, it just says "Getting Assigned Site" and "AutoDiscover Site" a few times. Nothing else.

I did a ccmclean with a computer in my lab but also one that is in the field (we have Remote Administrator software to remote into the computers as a backup). I haven't tried to manually install it yet bbut don't want to because I need to be able to push these with us having 1000+ computers.
0
 
schristeCommented:
I would say upgrade, SP1, and 2 had issues hence the SP3 release. With our site, we did the install of SMS 03, then SP2, and then installed SP3. Make sure to have client push disabled so you don't end up with a mix of clients out there. After SP3 is installed, then yea, you can install the clients through the push...right click the collection, choose install client and away you go.
0
 
lffitAuthor Commented:
Sounds like a plan but I don't believe it will be that simple for me.

What started this whole issue off is the log error in my first post with it not having a service account (although I have one defined) and it can't attach to the admin$ (although I verified it has credentials).

Any ideas what would be causing this?

I appreciate all your help so far. You've been to most helpful out of any replier in all my threads. I'm going home now but will begin upgrading SMS to SP3 on Monday. Reply when you can with any other troubleshooting ideas for the error above. I'm monitoring it through my blackberry.
0
 
schristeCommented:
Not sure yet, but to avoid this as being a possible issue with SP1 lets get SP3 going so you know you will be working with the latest version with all fixes applied. Unless anyone else wants to chime in and try to figure out what is going on with that possible permissions issue.

Also, I assume these are all Windows XP SP2 clients?
0
 
lffitAuthor Commented:
Alrighty, I have upgraded SMS to SP3. The installation went through flawlessly and also upgraded the remote consoles. But I'm still getting the same error listed in my first post but with an additional issue. Now it can't connect to the registry either. So now I have an upgraded site but back to square 1.
0
 
lffitAuthor Commented:
And yes, we run all XP SP2 clients with a couple 2000 machines trickled here and there but I'm not worried about those. They are slated to be refreshed in the next couple of months.
0
 
lffitAuthor Commented:
Ok, I'm up and running now. I actually solved my issue. It turned out that somehow my account credential entry dropped out of the Client Push Installation field. I swear I checked that from the get go but I guess not. I'm still rewarding the points to you since you helped me out so much. I do have another issue now where some of the clients in different collections aren't being assigned but I'm going to post that in new thread.

Thanks,

Jay
0
 
lffitAuthor Commented:
I ended up solving my own issue but the user helped me out in troubleshotting.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now