Dell Dimension will not recognize Drive "unknown device"

I am attempting to install a Seagate Barracuda hard drive (new and not formated yet) into a Dell Dimension 2400 computer with bios version A05.  The computer will not recognize this drive what so ever.  The drive does work, it was fine in another computer.  In the Dell bios the primary 0 drive is listed as "unknown device."  It is the only drive on the ribbon.  The ribbon is new and I have swaped with others, no help.   UDMA is enabled in the Dell bios.  I have a western digitial 40 gb that is old, but it seemed to work in the computer and recognize.  Is there a problem with seagate or is the bios for western digitial only?  I am very confused on this on.  I have replaced hard drives in many dell machines, this one has be stumped.  I also tried all the other jumper settings except slave.

Has anyone experienced this problem before.  
LVL 1
rhutzelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pghzooitCommented:
have you taken the jumper out all together?

0
PUNKYCommented:
Try reset bios see if it helps?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Davis McCarnOwnerCommented:
The drive should be jumpered for CS (cable select); but, I suspect your problem is it is larger than 127GB and the Dell Bios hates it.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

rhutzelAuthor Commented:
Yes:  Bios has been cleared:  no change
Yes:  I tried the no jumper and cable select option
No:  The hard drive is only 80 gigabytes

I am going to consider this a bad bios.  I know that all of your answers would be right any other time.
0
rhutzelAuthor Commented:
Thanks for trying
0
PUNKYCommented:
Is the problem solved yet?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.