• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2278
  • Last Modified:

Outlook 2007 using wrong GC, 'DS Server' doesn't work

We installed Exchange 2007 a few months ago, and against all advice, installed it into an environment that had both Windows 2000 and Windows 2003 DCs.  A lot of people think it couldn't be done, but there was docs out there and all went relatively smoothly.

Out of 100 users, about 10 of them couldn't connect through Outlook 2002, and I needed to set "DS Server" in 'HKCU\Software\Microsoft\Exchange\Exchange Provider' to the Win2k3 GC.  That woked well.  

My own personal computer which is running Outlook 2007 did not require such a fix until recently.  I uninstalled a bunch of stuff and all of a sudden I got an error message that the Exchange Server was unavailable.  I modified the registry but it didn't seem to do anything.  Then I ran a network analyzer (ethereal) and noticed that it was querying the wrong GC for the info.  So it apparently isn't using the 'DS Server' regsitry value.

I've verified that the registry key is entered correctly and I've rebooted the computer several times.

Does anyone have any idea why outlook would not be using the GC I tell it to in the DS Server setting?

Thanks.
0
adamdrayer
Asked:
adamdrayer
1 Solution
 
kieran_bCommented:
There is nothing wrong with 2000 DCs, so I am wondering where your advice came from.  As long as you have 1 2003 DC which is a GC, it is fine.

Using a DS Server reghack is no solution, and should not be necessary here if it is done right.  Remove that from your machine, reboot, and see what outlook throws up.
0
 
adamdrayerAuthor Commented:
My advice came from Microsoft.  Although possible, there is a lot more that must be done when you have a Windows 2000 DC in your domain.  You cannot use the GUI install interface and you must run certain powershell utilities after install.  Even then it still logs warnings constantly about one of the servers being a Windows 2000 DC.  

In addition, Windows 2000 cannot support the schema adjustments that are necessary for Exchange 2007 to work properly, so the schema must be queried on a windows 2003 GC.  This means that both Exchange and Outlook must point to a windows 2003 GC for schema queries.  The way to set this on the client-side is with the "DS Server" registry setting.  This solution was recommended to me by PSS and has worked for all but one of my computers.

I have repeatedly rebooted the server with and without the registry settings and still the queries are being directed to the old 2000 DC.
0
 
PeterSingerCommented:
The solution is to follow the article below.
http://support.microsoft.com/kb/927612 
A workaround until you make the change to the exchange server is to add the following registry key and point it to the correct domain global catalog server;

Click Start, and then click Run.
In the Open box, type regedit.exe, and then click OK.
Locate and then click the following key in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider
Note You may have to create the registry path.
On the Edit menu, click Add Value, and then add the following registry value:
Value name: DS Server
Data type: REG_SZ (string)
Value data: FQDN of the global catalog server  
Peter
0

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now