Can't access OWA locally with SSL

Hello everyone
Local access with port 80 works fine http://ipaddress/exchange
I generated a certificate, added it. Yet when I try to access OWA locally with https://ipaddress/exchange it does not work. It gives me this page cannot be displayed.
Help please.
LVL 1
Methodman85Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kieran_bCommented:
You manually created and added a certificate to SBS?

You know that it does that automatically if you use the wizard, right?

I would run the CEICWizard and see how it goes after that.
0
Methodman85Author Commented:
Sorry I guess I shouldn't of posted this in SBS, we don't have a SBS. Just plain Server 2000 running Exchange 2000
Even if the cert was invalid or incorrect, should I not see a different error message when trying to access locally?
0
kieran_bCommented:
OK, removed from SBS now.

If the cert was invalid or incorrect, it should give you an error - unless it wasn't installed right.

If you open up the IIS management console, right click on the default website and hit properties, what ports does it say it is listening on?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Methodman85Author Commented:
Thanks

TCP Port: 80
SSL Port: 443
0
kieran_bCommented:
Stupid question, but are you running IE7?
0
Methodman85Author Commented:
6, as all member servers are on Windows 2000
Question, does local access on port 80 work without port forwarding traffic from the firewall?
0
kieran_bCommented:
Any local access works without firewall port forwarding - it never touches the firewall.

Can you access it from the server itself?

https://localhost

?
0
Methodman85Author Commented:
Nope, no access from the server itself with https, http works instantly.
https gives me page cannot be displayed.
0
kieran_bCommented:
Can you delete the certificate and generate a new one?

How are you generating the cert?  CA?  Try this -> http://www.visualwin.com/SelfSSL/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Methodman85Author Commented:
do you really think it's the cert? shouldn't an invalid cert still work but give an error? Or is this a normal symptom with a bad cert?
0
kieran_bCommented:
I think it is IIS not liking the cert - if it is applied wrong, it could behave as though it isn't there (like it is now)
0
Methodman85Author Commented:
Alright I will give it a try first thing tomorrow, don't like working when I'm off work, thanks, I'll let you know.
0
Methodman85Author Commented:
Is there a self ssl util for server 2000, the one you suggested is only for 2003. I can't install it.
0
kieran_bCommented:
No, sorry, I didn't pay attention to that key point...

it was just an option anyway, you could also just simply remove the certificate from the default website, reboot, make sure it is gone, then install a freshly generated one from your CA.

Another option would be (assuming you have a .com domain name) buy a certificate from http://www.certificatesforexchange.com - they are ~$20, will not generate certificate errors, and come with support ;)
0
Methodman85Author Commented:
Thanks, I'm administering this server remotely, I just realized on newly created accounts Mail isn't being delivered from the outside
Older exsisting accounts work fine though. I was going to use StarCom's free SSL, but they need to send an email directly to one of three domain accounts.
postmaster@domain.com
hostmaster@domain.com
webmaster@domain.com
There was an exsisting postmaster account under a different domain email address from the domain that currently exsists so I deleted it and recreated it with the proper domain email. Internal and outgoing mail works fine, but inbound from the outside to that domain does not work.
Spam filter reports that the messages were accepted and delivered, no bounceback messages on the senders side, and like I said there are accounts that work fine.
I'm at a loss, the messages never actually reach the mailbox, as the items category within exchange system manager, under the mailboxes in question never changes when a message from the outside is sent.
Any ideas? I know this is a different issue now.
0
kieran_bCommented:
Put the failing email addresses in here and show me the error -> http://www.zmailer.org/mxverify.html
0
Methodman85Author Commented:
Thank You Sir!
It was indeed the cert, finally got the new one created and in place, works like a charm
thanks again!
Take care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.