Vista won't boot after installing video drivers

I'm running Vista 64bit with Asus 8500gt.(c2d e4500, 2gig ddr2, 1xsata, 2xata devices, 400w cm psu)
During system loading process, after green bar and before login screen,  loading stops with blank screen.
When I boot into safe mode, it works. Unistalling video drivers (nvidia 7.15.11.6222) let me load system normaly, and then video card is detected and drivers installed. Rebooting brings everything to starting point - vista stops loading before login. I have tried asus official release and latest nvidia forcware.
any ideas?

ps, everything worked fine untill today (video was ok with same drivers).  system was rebooted two times for unknown reason and then this issue.
LVL 2
MihailoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Forrest BurrisCommented:
http://www.guru3d.com. Download the MODIFIED nvidia display drivers for Vista 64bit. You do have the video card's power connection plugged in? Most 400W PS's don't come with power plugs for certain cards. A 400w PSU for a nice gaming rig is on the extreme low end.
0
MihailoAuthor Commented:
no, this card does not use "external" power. i could try with modified driver (but i'm not sure what's the point) since the card was working fine until today with official forceware. what could cause this behaviour? sure i'll try all available drivers if there is no better idea.
0
PUNKYCommented:
You can do a system restore to date that you knew it worked fine see if it helps.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

MihailoAuthor Commented:
no good. i tried system restore but mega-giga-super-vista keeps only 10 or somethnig latest restore points, and all of them are made AFTER last boot. (i don't turn off the computer for no resaon, so it's on for about two weeks). on the second tought, maybe this can't solve problem? maybe it's something else
0
PUNKYCommented:
I would backup data and do clean install on it, but guess that is not what you wanted. Also, I would test the card on other system see if it works just fine or it acts similar problem.
0
MihailoAuthor Commented:
ok i "solved" this problem. it's probably some electric charge or something? maybe card got stupid, or probably vista got stupid, i don't have better explanation. i removed a card to check it out, and when i put it back, everything got ok. strange, but i'm happy it works now (with any drivers i use - i wanted to make sure this is not a drivers issue).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.