Autodiscovery not working in exchnage 2007

Added an ssl cert to iis and autodiscovery is not allowing me to join new outlook clients to the domain. Help????It keeps saying name not found in address book.I have exchange 2007.
lkuhnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

consultkhanCommented:
Hi,
This is a known issue in exchagne 2007.You need to have a SAN certificate i.e. a certificate with multiple names.If case you are using a local CA certificate you can add this using the certficiate generation wizard from your CA intranet or through the command line console from exchagne 2007.
SAN:DNS=autodiscover.domain.com&dns=hostname&dns=mail.domain.com

thanks.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ATIGCommented:
Please review my autodiscover blog it will walk you through everything

http://exchange-genie.blogspot.com/
0
jjozCommented:
does adding servername.local as SAN entry really helpful ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.