USB ports provide power, but no functionality

I'm working on a Dell XPS which is about 4 years old.  Out of the blue, the 8 on board (6 back / 2 front) USB ports stopped working.  They provide power to devices that charge, but no functionality - for example a USB flash drive never lights up / works but my USB bluetooth headset charges.  

I've tried all of the usual fixes including removing/reinstalling the USB root hub in the device manager, flashing the BIOS, reinstalling the chipset drivers, checking IRQ steering, etc.  Nothing.  The computer does have a 4 port USB internal PCI card that does fully work, but I'd like to get the on board ports to work.  

At this point I feel like it's highly likely these ports are in some way damaged from a hardware perspective, but I thought if anyone had some insight on troubleshooting when ports are providing power, but no functionality.

Thanks.

cunninwAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zuechCommented:
You can use a boot up cd like Knoppix to test the ports. If something like a USB keyboard works off of a boot CD and not in Windows then it would point to a driver issue. If the keyboard doesn't work off the boot CD there is a good chance that the ports are dead. Here is a link to Knoppix.

 http://www.knoppix.net/get.php

What OS is installed? You have covered most of the basic USB troubleshooting techniques but here is an article that has a few more things to try. I think you covered all of them except the cabling. The second provides almost the same.

 http://support.microsoft.com/kb/310575

http://www.earthtym.net/USB-solutions.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
you may try these :
unplug pc from power for 30 minutes
then test
-----------------------
What happens when you start the removable service. Delete the upper filter and lower filter from here
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
usb device.
Delete upper and lower filter and restart the computer.
--------------------------------------------------------------------------
start>run>services.msc
look for Removable Storage Service. Is is set to Auto, and if not started, click the Start link in the top left...
In c:\windowsc:\windows\inf.  look for usbstor.inf -  If not found, copy from another PC. If you find it, right click it and select Install
See if it rebuilds the USB support...
----------------------
 copy the USBSTOR.SYS from a working PC to the bad one. (copy the old one somewhere else first)
normally located at c:\windows\system32\drivers
==============================================
Start the Registry Editor (Run -> Regedit). Check if under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the item 'DevicePath' points to '%SystemRoot%\inf'. Additional items, separated by semicolons, are ok but '%SystemRoot%\inf' has to be one of them.
Then delete the file C:\WINDOWS\inf\infcache.1 - XP will recreate it.
The INF folder and the infcache.1 file are 'hidden'. To see them in the Windows Explorer:
Menu 'Tools' -> 'Folder Options' Tab 'View', mark 'show hidden files and folders'
If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. A Windows repair install should correct this.
 Another thing to check is if the values 'FactoryPreInstallInProgress' and 'AuditInProgress' are set to '1' under
HKEY_LOCAL_MACHINE\SYSTEM\Setup
and
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Factory
They should be 0 or not present.
----------------------------------------
0
zuechCommented:
nobus, those are some good techniques to add to my normal routine. One question for you since I can see you have a good handle on USBs should something like Knoppix be used before trying the above since it seems like most of them are driver related and Knoppix would be using its own drivers? Then if it works in Knoppix move on to the registery changes after you have tried the basic techniques such as driver updates and so forth?

"What happens when you start the removable service. Delete the upper filter and lower filter from here
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
usb device.
Delete upper and lower filter and restart the computer."

What are the upper and lower filters?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

nobusCommented:
trying knoppix will :
1-chango NOTHING to your system
2-prove that the usb ports work or not
3-stays handy for later troubleshooting, copying from systems that don't boot, etc..

in short : the best you can do first !
0
cunninwAuthor Commented:
Thank you both for your excellent input.  The Knoppix suggestion was key and it did indeed prove that the USB problems were hardware related.  zuech I'll keep those advanced suggestions for USB fixed in my back pocket.  

What do you both think of an all-in-one hardware troubleshooting solution like PC Doctor [http://www.pc-doctor.com/].  Do you think that it's a good idea for a neighborhood tech?

Thanks again, great job!!
0
nobusCommented:
you can use that, not bad at all; or use separate diags on a bootable cd like ubcd :
http://www.majorgeeks.com/Ultimate_Boot_CD_Full_d4981.html      
i use this much more than pc-doctor, which i only use for starnge problems
0
zuechCommented:
I hear a lot of good things about Ultimate Boot CD. I use Hiren's Boot Disk just because that is what I found first and I would imagine that it has a lot of the same utilities anyway.

http://www.9down.com/Hiren-s-BootCD-9-3-KeyBoard-Patch-18605/
0
nobusCommented:
zuech - do not refer to hiren's it contains illegal software!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PC

From novice to tech pro — start learning today.