SLow file transfer from server to XP Pro SP2 machine

Using a UNC or Mapped drive to a network share to a server running SBS 2003 RC2 I experience SLOW file copies from the server to the client (get).  Things go great in the other direction (push).  I have several clients. This is the only one doing this.  I can copy files from other clients to this pc no problem and I can copy files from external devices like flash drives to this pc. Only happens when I try to copy from the server.  I have placed the pc in another location, replaced patch cables, hard coded the nics on server and client and even replaced the NIC to the client.  All devices o the same subnet.  All clients running XP Pro.  There are no odd errors in event viewer.  I set the LANMAN parameters to 0 on the server just to see if that would help.  It did not.
aksnarfle08Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

top_rungCommented:
Have you checked the duplex settings on the NIC and Switch?
0
hbustanCommented:
I agree with top_rung

Usually a mismatch between the switch and server settings could have an impact on transfers and access. This also goes for the clients that connect to the switch as well.

Things to check:

1. Full or half duplex settings on both (machine's NIC and Switch port settings)
2. Speed of NIC & switch port (10 Mbps or 100 Mbps or 1 Gbps)

Having a mismatch doesn't take the lowest of the 2, it actually performs much worst due to collisions.
 
0
MarkMichaelCommented:
You can check these by looking at your Network card from withing Device Manager and click on the Advanced tab. It is best to have the negotiation as 'auto', however if it is as auto at the moment and you are getting issues. Change it to 100 Full Duplex (etc...) for testing...
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

top_rungCommented:
Exactly.. don't mismatch them.  If for instance the switch is set to 100 Full, don't select auto (which is the norm) on the NIC. Set NIC to 100 full.   Although in theory it should work, there can be problems.   Match them on both sides where possible.

From Cisco...

"Some third-party NIC cards can fall back to half-duplex operation mode, even though both the switchport and NIC configuration are manually configured for 100 Mbps, full-duplex. This is because NIC autonegotiation link detection still operates when the NIC is manually configured. This causes duplex inconsistency between the switchport and the NIC. Symptoms include poor port performance and frame check sequence (FCS) errors that increment on the switchport. In order to troubleshoot this issue, try to manually configure the switchport to 100 Mbps, half-duplex. If this action resolves the connectivity problems, this NIC issue is the possible cause. Try to update to the latest drivers for your NIC, or contact your NIC card vendor for additional support."


"Autonegotiation issues can result from nonconforming implementation, hardware incapabilities, or software defects. When NICs or vendor switches do not conform exactly to the IEEE specification 802.3u, problems can result. Hardware incompatibility and other issues can also exist as a result of vendor-specific advanced features, such as autopolarity or cable integrity, which are not described in IEEE 802.3u for 10/100 Mbps autonegotiation. Generally, if both the NIC and the switch adhere to IEEE 802.3u autonegotiation specifications and all additional features are disabled, autonegotiation must properly negotiate speed and duplex, and no operational issues exist."


0
aksnarfle08Author Commented:
As stated above.  hard coded the nics on server and client as a troubleshooting method.

 I did this as the auto was the original setting for everything.  Problem exisits regardless of how I have changed the speed and duplex setting on the NIC's.  and duplex mismatch will create tons of collisions , which is not happening as I have sniiffed using ethereal and netmon..  So in either Auto or hard coded the speed and duplex are not the issue.  Also note.  another client same settings, no problem
0
PlaceboC6Commented:
If you are running service pack 2 on the server,  you will have the scalable networking pack installed.
If you have a new enough network card in the server it will take advantage of new technologies called Receive Side Scaling and TCP Offload.

These are notorious for causing random network issues to include random speed problems with different clients.

Locate and set the following registry keys to 0.  Then reboot.

Try your test again.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

" EnableTCPChimney
Type: REG_DWORD
Values: 1 (enabled) 0 (disabled))

" EnableRSS
Type: REG_DWORD
Values: 1 (enabled) 0 (disabled))
 
0
hbustanCommented:
You mentioned that you hard coded the nics on the clients and servers.

Did you hard code it on the Switch ports as well?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PlaceboC6Commented:
Did you get a  change to try the regedits?
0
aksnarfle08Author Commented:
Greetings All.   Here is what seems to have solved the problem.  Since auto negotaition for the gigabit standard is more intense than 10/100 I chose to leave those set to auto on those clients, and the switch ports.  The 10/100 Nics are set to 100 full and the switch ports they connect to are set to 100 full.  This is how I set it up when this issue came up.  I verified this more than once.  What I did not do AFTER changing these settings was power cycle my switch.  I did this the other day and it now works.  All my settings are as stated above.  Sounds squirrley I know but it worked.  I did power cycle my switch before even posting my question here so I know that in itself was not the fix.  Thanks for all the input as typing all this out help me walk through the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.