Citrix client questions

Hi

We are running PS4 on Windows 2003 Servers. There are two adjusments that I'd like to make, but I can't seem to find the options for these anywhere and was wondering if someone could help -

a) At the moment, when users want to save anything, they have the option of saving onto the desktop as well as their remote drives. Since this is the server desktop (we have client drive mapping disabled), I'd like to disable this, however cannot see any option to?

b) If the application crashes for users, they normally kill their Citix session too. However, when they log back in again, they are presented with the same 'crashed' screen and the Citrix session needs to be reset on the server. Is there any setting/ time out that can avoid this? Disconnection time out?

c) At the moment, the application is published to an AD group. The users click on the Citrix client icon on their desktop, have to authenticate, then have to authenticate to the application itself (not AD related) before being able to launch it. Is there anyway that when they launch the Citrix published app icon they go straight to the application logon screen? I understand this would be pass through authentication, but can't see anyway to change it once the application has already been published?

Any help would be greatly appreciated!!

Thanks
LVL 3
kam_ukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sadique_dawoodCommented:
Soulution to Problem 1:
Disable the Active Desktop.
 Step 1
Start> Run> tscc.msc
Step 2
In The Left Pane Click on Server Setttings.
Step3
In the right Pane Double Click on Active Desktop and then Check the Box for Disable Active Desktop.

Possible Solution to Problem 3
If the users are using only that application in the session then You might try Setting up so that Only that specific app launches on Logon



Solution to

Now ask all your users to logoff and then log back on.
If This does not Work

Change the Local Machine Policy from using
gpedit.msc


Solution to Problem 2
Step 1
Start> Run> tscc.msc
Step 2
In The Left Pane Click on Connections.
Step 3
In the Right Pane Double Click on the RDP-tcp connection
Step4
Click on the seeions Tab now.
Step4
Check the box for OverRide user Settings
Step5
Now Change the setting for "End a disconnected Session" to 1 Minute
(Drawbacks If any user disconnects his her session and does not lagback on immediately (within 1 Minute)then they lose all their work. Also the users will have to wait for At least 1+ minutes to log back on.

Step 1
Start> Run> tscc.msc
Step 2
In The Left Pane Click on Server Setttings.
Step3
In the right Pane Double Click on on the RDP-tcp connection
Step 4
Click on the Environments Tab

Now you ca do two things
 Option A)
Select radio button for "Run Initial Program specified.............................................."

and the specify the Program in the TS user Profile in the AD

Option B)
Select the Radio button for "Start the following program........................................."
and then Give the network path or Local path to the application.
Choose
0
Cláudio RodriguesFounder and CEOCommented:
Nope, the suggestions do not work.
First of all disabling active desktop will not prevent users from saving stuff to the desktop.
Assuming each users is logging on with their own accounts, the 'Desktop' is really a folder on C:\Documents and Settings\%username%\Desktop (assuming you did not remap the Citrix server drives).
So saving to the desktop is bad as this folder is on the user profile so this will grow overtime and if roaming profiles are in use logons/logoffs may take forever. What you need is to REDIRECT the Desktop folder to a network location, unique for each user. Something like a Desktop folder under their home directories. Windows has built-in group policies to do the desktop folder redirection. Just check for more info here:
http://www.windowsnetworking.com/articles_tutorials/Profile-Folder-Redirection-Windows-Server-2003.html

For the disconnection issue you must set a timeout on ICA-tcp and NOT RDP-tcp as this is a Citrix box and I assume users are logging in using the Citrix client.

For your final question, once you launch TSCC.MSC on the server and go to ICA-tcp you will see a tab where there is an option saying 'Always prompt for password'. UNCHECK that.
And of course on the client side you will need to use passthrough authentication. I think that can be set by right clicking the program neighborhood icon on the system tray or directly on the ICA client.


Cláudio Rodrigues

Microsoft MVP
Windows Server - Terminal Services
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kam_ukAuthor Commented:
Thanks...

For question 3, 'always prompt for password' is unchecked...rather than going to each program neighbourhood icon, is there any way to enable pass through on the application/ ICA Client settings on the server?

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

BLipmanCommented:
If the server is running PS4.0 it is in the Citrix Connection configuration tool; in PS4.5 it is in TSConfig.  
http://support.citrix.com/forums/thread.jspa?forumID=137&threadID=87126&messageID=577529&

You need to go into the ICA Settings in your Program Neighborhood to enable Passthrough Authentication.  This is in addition to having it enabled in your farm.  You had the option at the time of installation.  If you are using the Web Interface, you need to configure the client authentication methods in the AMC.  Anyway, post if you are having difficulties.  
0
kam_ukAuthor Commented:
Thanks

We are using PS4, and sorry, still having difficulty with this :(

I'm not sure which specific ICA settings within PN I need to change to enable Passthrough?
0
BLipmanCommented:
In the Program Neighborhood, click Tools, ICA Settings, check "Pass-through Authentication" and "Use Local Credentials".  You will need to reboot most likely.
0
kam_ukAuthor Commented:
" the Program Neighborhood, click Tools, ICA Settings, check "Pass-through Authentication" and "Use Local Credentials".  You will need to reboot most likely. "

Thanks, I can see these settings, but they are greyed out...any idea on how to set this centrally if possible, or what permissions I need to give the users so that I can change this on each PC?
0
BLipmanCommented:
Checking Pass Through should "un-grey" the other option...does it do this?
0
kam_ukAuthor Commented:
Nope,  Pass-Through Authentication is greyed out too. :(
0
BLipmanCommented:
Hmm, very strange, can you install the client "clean" on a different PC and see if it is greyed out there too?  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.