• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 245
  • Last Modified:

Need another set of eyes on this route statement. Trace route is looping around

Have three locations, all have T1's between them.  Cisco 1720's at all three.  
From Site A:
I can ping both site B fa0 and C fa0

From Site B:
I can ping site A fa0
I cannot ping site C fao

From Site C:
I can ping site A fa0
I cannot ping site B fao

If I try to do a trace from site A to site B fa0 it first tries to go through S0 at site C, then back to S0 at site B, then back to S0 at site C, then it appears to be completed ... although my last site was the incorrect one.
If I try to do a trace from Site A to site C fao it does the opposite.  See below.

Main1721#trace 10.1.2.1

Type escape sequence to abort.
Tracing the route to 10.1.2.1

  1 192.168.1.35 8 msec
    192.168.1.25 8 msec
    192.168.1.35 4 msec
Main1721#trace 10.1.3.1

Type escape sequence to abort.
Tracing the route to 10.1.3.1

  1 192.168.1.25 4 msec
    192.168.1.35 8 msec
    192.168.1.25 8 msec
Main1721#

If I do a trace from site C to A here is what I get:
North1720#trace 10.1.1.3

Type escape sequence to abort.
Tracing the route to 10.1.1.3

  1 192.168.1.30 8 msec 8 msec *

If I trace from Site C to Site B here is what I get.
North1720#trace 10.1.2.1

Type escape sequence to abort.
Tracing the route to 10.1.2.1

  1 192.168.1.30 8 msec 8 msec 8 msec
  2 192.168.1.35 16 msec 12 msec 16 msec
  3  *  *  *
  4  *  *


Exact thing happens from Site B to A and Site B to C.

I've mellowed over this config for hours and I can't see the problem.  I would appreciate it I could get an experts opinion.


north1720.log
main1720.log
crowne1720.log
0
ibtaya
Asked:
ibtaya
  • 4
  • 3
2 Solutions
 
Don JohnstonInstructorCommented:
Your first problem (not that there are others) is that both T1's are the site A using IP addresses from the same network. Every interface on a router must be connected to different networks. Until that's resolved, any unexpected routing behavior is possible.

BTW, how did you even get the IP addresses assigned like that. Whenever I tried an addressing scheme like that, I get a message "IP address overlaps with interface..."
0
 
JFrederick29Commented:
First of all, I would change all of your serial interfaces to /30's and not have them all in the same subnet.  I would also run EIGRP over the serial links and remove all your statics to the other sites.

Main:

int s0
ip add 192.168.1.1 255.255.255.252

int s1
ip add 192.168.1.5 255.255.255.252

router eigrp 1
network 192.168.1.0 0.0.0.3
network 192.168.4.0 0.0.0.3

no ip route 10.1.2.0 255.255.255.0 192.168.1.25
no ip route 10.1.3.0 255.255.255.0 192.168.1.35

Crowne:

int s0
192.168.1.6 255.255.255.252

router eigrp 1
network 192.168.1.4 0.0.0.3

ip route 0.0.0.0 0.0.0.0 192.168.1.5
no ip route 0.0.0.0 0.0.0.0 192.168.1.20
no ip route 10.1.0.0 255.255.254.0 192.168.1.20
no ip route 10.1.3.0 255.255.255.0 192.168.1.30
no ip route 10.92.0.0 255.255.0.0 192.168.1.20
no ip route 10.106.0.0 255.255.0.0 192.168.1.20
no ip route 10.140.0.0 255.255.0.0 192.168.1.20
no ip route 10.156.0.0 255.255.0.0 192.168.1.20
no ip route 10.245.0.0 255.255.0.0 192.168.1.20

North:

int s0
ip address 192.168.1.2 255.255.255.252

router eigrp 1
network 192.168.1.0 0.0.0.3

ip route 0.0.0.0 0.0.0.0 192.168.1.1
no ip route 0.0.0.0 0.0.0.0 192.168.1.30
no ip route 10.1.0.0 255.255.254.0 192.168.1.30
no ip route 10.1.2.0 255.255.255.0 192.168.1.20
no ip route 10.92.0.0 255.255.255.0 192.168.1.30
no ip route 10.106.0.0 255.255.255.0 192.168.1.30
no ip route 10.245.0.0 255.255.255.0 192.168.1.30
0
 
JFrederick29Commented:
Hey there donjohnston,

You can actually have overlapping IP's on serial interfaces all though I don't know why you would do it.  Not the same for ethernet though...
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Don JohnstonInstructorCommented:
Really?

So what does the router do when it needs to get to one of the IP addresses at the other end of one of the links? There's no way to determine which interface to use so how does it know which interface to send the packet out of?
0
 
JFrederick29Commented:
Yeah, never really thought it through, just saw an article once regarding it and obviously the router let it happen.
0
 
Don JohnstonInstructorCommented:
I know you can get the address assigned. Just copy the config from a TFTP to startup. :-)

I just can't imagine that it would work very well.
0
 
ibtayaAuthor Commented:
The eigrp 1 you wanted me to put in for Site A 192.168.4.0 0.0.0.3, shouldn't that actually be 192.168.1.4 0.0.0.3?

I'm new at this and just learning.  Other than that it's back up and going.  I did have switch the cable in S0 and S1 around.

On the conversation above, I consoled directly into routers to set them up.  When I put them in place they both came up regardless of my subnet problem.
0
 
Don JohnstonInstructorCommented:
Actually, it should be

network 192.168.1.0 0.0.0.3
network 192.168.1.4 0.0.0.3
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now