Cannot get internet on Virtual Machine.

Hi. I am having problems getting internet access on my virtual machine Linux. I have my setting to NAT but still no internet can someone please assist me with this issue I am using workstation 6 with Suse Linux.
jschmuffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hbustanCommented:
I have Workstation 6 with SUSE as well.

NAT works for me. Try Bridging - does that help? Perhaps you have some sort of firewall software on your main system?

Try to check the IP address of your SUSE using:

ipconfig -a
0
jschmuffAuthor Commented:
I am running a dlink router could that be the problem? If so how can I configure my router to allow access from vmware?
0
hbustanCommented:
You shouldn't change anything from the router.

The virtual machine will act like another computer.

If you use NAT, the NAT process is between your own PC and the Virtual Machine (SUSE) (Not the router). You main PC will gave another fake IP to your virtual machine and your PC will act as a router to your SUSE.

If you use Bridging, the your virtual machine (SUSE) will act like a separate machine and tries to collect a new IP from your router.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jschmuffAuthor Commented:
I have tried both NAT and Bridged and still unable to access the internet in Linux on VMWare
0
hbustanCommented:
If you can issue the command "ipconfig -a" from SUSE for both options and give us the results, perhaps it will make more sense to us what exactly is happening at your end.

Also provide us with your machine's IP and your router's IP
0
jschmuffAuthor Commented:
The results of SUSE in the command line is a lot of information to look at and type down is there an easier way to give you the results maybe less of the information getting my routers ip and my ip is easy I dont know what all that is in SUSE though.
0
hbustanCommented:
Yes just show us the IP address and netmask for each interface (ignore the rest of the details)
0
jschmuffAuthor Commented:
Windows XP IP: 192.168.100.2
Router IP: 24.230.45.69

SUSE inet: 10.0.0.10
SUSE bcase: 10.0.0.255
SUSE Mask: 255.255.255.0
0
hbustanCommented:
The IPs on your SUSE look funny.

From your windows XP, can you give me the IP for the following using ipconfig /all:

 VMware Virtual Ethernet Adapter for VMnet

Also, the SUSE IP shown above is used when bridged or NAT?

Can you try both: Bridge and NAT, and see if the IP on the SUSE changes?

Perhaps your SUSE IP is hard coded and not picking up from DHCP????
0
jschmuffAuthor Commented:
VMnet8
IP: 192.168.60.1
sub: 255.255.255.0

VMnet1

IP: 192.168.203.1
sub: 255.255.255.0

Local area connection

IP: 192.168.100.2
sub: 255.255.255.0
router IP: 192.168.100.1




0
hbustanCommented:
This means your SUSE is not set up correctly for whatever reason.

VMnet8 is your NAT IP address for VMWare which means your SUSE IP address should look like:

IP: 192.168.60.2
sub: 255.255.255.0
Gateway: 192.168.60.1

Try setting it manually on SUSE using ifconfig when set to NAT option in VMWare and I believe you will gain access to the Internet that way.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jschmuffAuthor Commented:
ok I am new to linux what commands can I use with ifconfig to change the ip and stuff what about yast?
0
hbustanCommented:
You can use YAST as well to configure your IP address settings - actually do it from there so the changes will stay permanent.

Also from YAST if DHCP is not set, then you can set it to DHCP instead and check if your new IP looks like what I mentioned above - otherwise set them manually from YAST.
0
jschmuffAuthor Commented:
Ok this is what I got I typed in this in command prompt for vista.

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : dlinkr
   Link-local IPv6 Address . . . . . : fe80::b0e8:ce28:32ef:788a%8
   IPv4 Address. . . . . . . . . . . : 192.168.100.2
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.100.1

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::99c0:836:9cc1:222e%10
   IPv4 Address. . . . . . . . . . . : 192.168.186.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::f533:e83b:cf6f:c660%12
   IPv4 Address. . . . . . . . . . . : 192.168.2.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Local Area Connection* 7:

   Connection-specific DNS Suffix  . : dlinkr
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.100.2%15
   Default Gateway . . . . . . . . . :

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.186.1%11
   Default Gateway . . . . . . . . . :

Tunnel adapter Local Area Connection* 10:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.1%13
   Default Gateway . . . . . . . . . :

This is what I get when I do ifconfig in linux with static settings

inet 192.168.186.2 bcast 192.168.186.255 subnet 255.255.255.0

with DHCP set

inet 192.168.2.128 bcast 192.168.2.255 subnet 255.255.255.0
0
hbustanCommented:
OK the DHCP looks right in this one assuming Ethernet Local Area Connection 3 maps to VMNet 8.

With DHCP, are you able to connect to the Internet now? Seems like now it should work.

If not, can you "ping 192.168.2.1" from SUSE successfully?
0
jschmuffAuthor Commented:
how can I ping 192.168.2.1?
0
hbustanCommented:
Set DHCP for your SUSE, and from a command Terminal screen, do the following:

>ping 192.168.2.1

also try:

>ping 192.168.100.2

also:

>ping 72.14.207.99

Do they respond with amount of time it takes for the packets to go and come back or does it give you an error? If an error occurs, for which of these 3 pings?

if it works correctly, then most likely your Internet should work as well unless your DNS is not working. To test your DNS, try the following from SUSE:

>nslookup google.com

Does it give you a result in IP?
0
jschmuffAuthor Commented:
I pinged 192.168.2.1 and it just kept going and going.
I pinged 192.168.100.2 I get "pinged 192.168.100.2 (192.168.100.2) 56(84) bytes of data"
 and same thing for 72.14.207.99
and when I did nslookup google.com I get timeout no server could be reached.
0
hbustanCommented:
From the terminal (command) screen, issue the following command:

>route

You should have 1 entry for destination "default" and its gateway should be something like 192.168.2.1

Is this the case? If you do not have any "default", try issuing the following command:

>route add default gw 192.168.2.1

Does it work now? If not, give me the results of your "route"
0
jschmuffAuthor Commented:
I have 4 entries. on for 192.168.2.0 no gateway, Link Local no gateway, loopback no gateway and default 192.168.2.1
0
hbustanCommented:
This look correct

do you have a file called /etc/resolv.conf

Does it have any values? What are they? It should look something like this (192.168.2.1 being your DNS server - if your DNS server is something else, replace this IP with that):

search localdomain
nameserver 192.168.2.1
0
jschmuffAuthor Commented:
ok I did that because it was set all wrong. so now it looks like what you have at the bottom of your post. still nothing no internet.
0
hbustanCommented:
what is the exact error message you get after the following command? Or is it working now?:

>nslookup google.com

also what is the exact result from the following command?:

>traceroute 72.14.207.99
0
jschmuffAuthor Commented:
When I type in nslookup google.com I get:

;; connection times out; no server could be reached

and for traceroute 72.14.207.99

traceroute to 72.14.207.99  (72.14.207.99), 30 hops max, 40 byte packets
1 * * *
2 * * *
3 * * *
etc.... same all the way down to 30
0
hbustanCommented:
For the nslookup, you should get something like this:

Server:         x.x.x.x
Address:      x.x.x.x#53
Error Message or Success Message

I am interested in seeing what IP address is returned before the error message appears.


For the traceroute, it seems very strange. Are you sure Line 1 is not showing the IP address of your default gateway (192.168.2.1)? This should be the very 1st hop unless your default gateway is not reachable. You said you could ping 192.168.2.1.

Can you issue the following command:

>route

and give me the results as well
0
jschmuffAuthor Commented:
After typing in route I get:
Destination     Gateway     Genmask           Flags  Metric  Ref        use    Iface
192.168.2.1         *              255.255.255.0     U          0       0            0      eth0
link-local              *               255.255.0.0        U          0        0           0       eth0
loopback             *               255.0.0.0            U          0        0           0       lo
default          192.168.2.1   0.0.0.0                 UG       0        0           0       eth0

this is exact so is what what I posted before for nslookup there was no server and no address just the error message:
;; connection times out; no server could be reached
0
hbustanCommented:
OK, then try

>nslookup google.com 192.168.2.1

Does that do anything?

Can you also try to turn off any firewall on your Vista machine (whether it is Microsoft or Symmantec) - perhaps that is blocking access??????
0
hbustanCommented:
I am really confused since the setup looks correct - there is no reason why this is not working
0
jschmuffAuthor Commented:
says same thing ;; connection times out; no server could be reached
I turned off the firewall on vista when I installed it and not sure what the issue is here.
0
jschmuffAuthor Commented:
Ok lets assume I just installed vmware and suse linux server 9 on my vista machine. I notice I dont have internet. What are the steps I need to do to getting internet on my virtual machine? I have done everything you have told me to and nothing. I dont know what the problem is exactly or why this isnt working.

I type this is command prompt for vista I get this:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Aspire
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : dlinkr

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : dlinkr
   Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
   Physical Address. . . . . . . . . : 00-15-F2-B0-A8-BC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::b0e8:ce28:32ef:788a%8(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.100.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, March 01, 2008 12:02:58 PM
   Lease Expires . . . . . . . . . . : Saturday, March 08, 2008 12:02:58 PM
   Default Gateway . . . . . . . . . : 192.168.100.1
   DHCP Server . . . . . . . . . . . : 192.168.100.1
   DHCPv6 IAID . . . . . . . . . . . : 201332210
   DNS Servers . . . . . . . . . . . : 192.168.100.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
1
   Physical Address. . . . . . . . . : 00-50-56-C0-00-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::99c0:836:9cc1:222e%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.186.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection 3:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
8
   Physical Address. . . . . . . . . : 00-50-56-C0-00-08
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::f533:e83b:cf6f:c660%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.2.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

   Connection-specific DNS Suffix  . : dlinkr
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.100.2%15(Preferred)
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 192.168.100.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{624C7051-037E-4187-B289-7F429B51E
18B}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.186.1%11(Preferred)
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 10:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{E0FAB77A-BD25-4CAB-9A27-E13255B6E
820}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.1%13(Preferred)
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Disabled
0
hbustanCommented:
Basically if your Vista is already connected to Internet, when you install VMWare with NAT and install SUSE as a virtual machine with DHCP, that's it - you do not need to configure anything else. Your Vista VMWare will act as a DHCP server for your SUSE virtual machine and provide it the necessary IP and settings to go through NAT.

Regarding the setup above,

The only difference I have in my Vista, is I do not have Tunnel adapter enabled for that connection (in your case the last entry Tunnel Adapter Local Area Connection *10). I'm not sure how you would disable it but perhaps by going to your network properties for "Local Area Network Connection 3" and disable TCP/IPv6.

Can you try the following Pings from SUSE:

>ping 192.168.2.1

>ping 192.168.2.2

0
hbustanCommented:
Alternatively, you can try to install another Virtual machine making sure you select NAT this time and see if that works.
0
jschmuffAuthor Commented:
I didn't get it working correctly but I think that is cause it is a pre-installed image I ran off this dvd from this book I got "Novell's Guide to Comptia's Linux+"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.