RPC over HTTPS (Outlook Anywhere) won't work on Vista

I've got a brand new Dell XPS 420 desktop running Windows Vista Home Premium. I'm trying to set up Outlook to connect to my work e-mail, but so far can't get anything to work.

I've got RPC over HTTPS set up exactly the same on several other Windows XP boxes, with both Office 03 and 07, so I know my outlook configuration is correct.

I've tried both Office 2003 and 2007 on the Vista machine, but i get the same results on both: "The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action."

I've researched this and made a few registry changes that have been suggested (I don't remember exactly which at the moment), as well as disabling IPv6 and Windows Firewall.

I can connect to OWA or /rpc with no certificate warnings.

Thanks in advance for anyone who can help. I really don't want to reformat a new machine right after I moved all my data over.
LVL 1
radicalsupportAsked:
Who is Participating?
 
radicalsupportConnect With a Mentor Author Commented:
I established a VPN connection to the computer and set up exchange. Once I disconnected the VPN, RPC over HTTPS kicked in and it's worked great ever since.
0
 
radicalsupportAuthor Commented:
I have looked over that question and answer, but I'm not getting a certificate error. I have added the certificate as a trusted root authority, as well as in my personal certificate store, but neither have changed anything.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
murgroupCommented:
If your rpc settings are the same on both machines, that narrows it down to the cert. Vista is very particular about the certs. Is your ssl cert a third party cert? if so download their root CA and install it on the vista machine. Or install the current cert in Vista's trusted root authority store manually.
0
 
radicalsupportAuthor Commented:
The certificate was issued by Equifax Secure Global eBusiness CA-1. I believe it was already in my Trusted Root Certificate Authorities, but I imported it just to be sure but it did not resolve the issue.

The current cert was added to the root authority store manually as well, but again did not help.
0
 
murgroupCommented:
Hmmm, that cert should just work. Try opening Outlook from the start, run, Outlook -rpcdiag and see if that gives you a clue.
did you turn off user account control and Internet explorer security in Vista?
0
 
radicalsupportAuthor Commented:
Running outlook -rpcdiag results in two entries:

Server name: ---
Type: Directory
Status: Connecting

Server name: mail.myserver.com
Type: Referral
Status: Connecting

They just stay there until disappearing upon the "The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action." error message.

User account control is off. Internet Explorer Protected Mode is turned off for the Local Intranet Zone (which my *.myserver.com is in).
0
 
cramomMIACommented:
Any updates or resolutions on this one?
0
 
radicalsupportAuthor Commented:
Nope, same problem, just waiting on the next suggestion.
0
 
radicalsupportAuthor Commented:
I'm still waiting for any suggestions I can get on this issue. If anyone can help, I would really appreciate it.
0
 
radicalsupportAuthor Commented:
I'd much rather actually get a solution for the issue.
0
All Courses

From novice to tech pro — start learning today.