How to get data flowing from internal interface to internet

Just got this Cisco ASA 5505, had allot of problems with all other routes I had - decided to get a REAL device. Only thing is, my knowledge seems to be way to light to get this thing working.

Configuered it using the startup wizard, I though I had it all right, but I am not getting to the internet. What am I doing wrong?

Setup: [internal network] -> [ASA 5505] -> [cable modem] -> ISP

I attached the configuration below - any idea where I went wrong?
result of: show running-config
 
ASA Version 7.2(3)
!
hostname THomeCiscoAsa
domain-name toalsys.com
enable password *********** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.2.2.3 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 24.151.120.8 255.255.255.0
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 10.3.3.1 255.255.255.0
!
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd *************** encrypted
ftp mode passive
 
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 24.151.8.211
 domain-name toalsys.com
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 10.2.2.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 24.151.120.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.2.2.0 255.255.255.0 inside
no snmp-server location
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 10.2.2.188-10.2.2.200 inside
dhcpd dns 24.151.8.210 24.151.8.211 interface inside
dhcpd domain toalsys.com interface inside
dhcpd enable inside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
smtp-server 10.2.2.24 10.2.2.22
prompt hostname context
Cryptochecksum:a3601ce5f05993f0800b9116ee29c01f
: end

Open in new window

LVL 2
vtoalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

batry_boyCommented:
Have you verified with your ISP that the public IP address on your outside interface is correct?  Most cable modem companies push out public IP's via DHCP...does yours, or is your existing static address assignement on the outside interface correct?

From the CLI on the ASA, can you ping your default route (24.151.120.1)?  If so, can you ping an Internet host, say 4.2.2.2 and get a reply?
0
vtoalAuthor Commented:
I have a static IP with my ISP, currently I have a netgear router that connects and I want to replace.
I can't ping anything, the data does ot seem to go from the outside interface and I do ot get a reply - it all dies in it's tracks. No clue - the configuration looks correct to me and i can't ay why it is not happening.

Is ther some kind of logging I can turn on to give me better error messages?
0
batry_boyCommented:
If you're using the same public IP address that was on the Netgear router, you may need to either power cycle the cable modem or whatever device your ASA outside interface is plugged into, or it may be that Comcast is doing some type of MAC filtering such that it allows traffic from the netgear's MAC address, but not the ASA's MAC.  Have you called Comcast to see if they do such filtering on your connection?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vtoalAuthor Commented:
It was actually the next thing I was going to look at after I make sure that the ASA is configured correctly. the only thing I am not sure of yet is that I get an error on the ASA: tracing a packet over IP/port 80 from the inside interface to the ISP router it stps at the NAT with the error "(acl-drop) Flow is denied by configured rule"
0
vtoalAuthor Commented:
I used the MAC address of the old router and shut things down for a while before restarting it. Will investigate further if the ISP is actually employing MAC address filtering or if turning the cable modem off for a prolonged time was what made the difference. In any case - thanks!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.