Entourage 2004 and 2008 error connecting to exchnge

I am new to the Mac world

I have two macs that are getting the same error message on them when I open Entourage.  Both the 2004 and 2008 edition are saying"unable to establish a secure connection to "domain.com" because the correct root certificate is not installed."

I have the certificate but am unsure of how to install it in the correct place.  I thought i had, but ai guess i am not because i am getting the error message still.

these macs have the new OS on them, leopard.

please help.
LVL 1
chughubertAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
0
strungCommented:
Here is some Leopard specific information you should read if you are using OS 10.5 as the manner of handling X509 Anchors has changed:

http://blog.entourage.mvps.org/2007/11/leopard_update_breaks_entourage_support_for_exchange_ssl_roo.html


Spefically, note the Nov. 18 posts.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.