Unable to install D-Link Bluetooth Adapter

Issue is trying to set up a D-Link Bluetooth 2.0 USB adapter on a Dell Inspiron 4150 laptop.  Computer is WinXPSP2 w/first gen USB 1.


The initial installation begins and completes normally up to the point where the installation asks to Please plug in the Bluetooth device and click OK button.

Plug in the device, wait about 5 min, then begins the infinite DO-Loop of  asking to plug in the device.

A little investigation in the hardware manager reveals that windows doesnt not appear to be detecting the device and associating the drivers which should have installed prior to the hardware connect prompt.

In an attempt to work around the issue, multiple re-attempts were tried w/the same conclusions.  To include a completely separate installation on a desktop computer which lives right next to the laptop&same issues.

I also tried downloading the install software from d-link, and running the install from the harddrive instead of CD w/same hangup.  I finally tried to brute force the driver to the device by working directly from device manager and pointing to the unzipped files from the downloaded installation files.  This at least cleared all the question marks in the device manager AND allowed a driver other than the XP generic Bluetooth driver to run the device.

However&the install never appeared to work, and even after clearing all the hardware question marks in device manager and appearing to have the hardware working, the Bluetooth manager D-link provided doesnt see the device as well as after trying to pair the device w/my palm by searching for pairable devices it obviously is not transmitting anything to link up with.

SO THE QUESTION.

Looking for ideas on getting this hardware to run on my laptop.  Services to disable in Services and Applications? (aka computer management)&etc.?

Any ideas are appreciated.

E
B1DUDEAsked:
Who is Participating?
 
PCBONEZConnect With a Mentor Commented:
Okay now that I know the model:
I saw some reports on the web that the drivers supplied on the CD do not work properly with XP SP2 -BUT- there are genaric drivers in XP SP2 that work just fine.

I suggest,
You uninstall the CD drivers (not the software if you can avoid it).
Shut down.
Install the drevice.
Reboot and let XP choose drivers.
Run Windows update just on the off chance there are newer XP drivers.

If that doesn't work then try this:
http://support.dlink.com/faq/view.asp?prod_id=2146&question=DBT-120_revB4

Let me know if it works.

.
0
 
ded9Commented:
Hi,

 What you need is a

pcmcia usb 2.0 card

http://www.usbfirewire.com/Parts/rr-usb-usb2cb.html


to make the blue tooth work.


Ded9
0
 
PCBONEZCommented:
I think you have a dud D-link.

.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
B1DUDEAuthor Commented:
ded9....Are you thinking the D-link is not USB 1X reverse compatible?

PCBonez....We live in a fairly remote area...w/a small supply of computer stuff available locally.  You think an exchange in hardware would be the ticket?
0
 
PCBONEZCommented:
Bluetooth Adapters should be 2x/1x compatable.
Specifically, it might be slower at 1x but it should at least function.

It seems your install is getting to the point where it has to recognize the adapter and it can't find one so Windows doesn't install the driver.
3 possible causes.
USB port is bad. (Not it if it works for other things.)
Glitch in the install program. (D-link would have a patch by now.)
Bad bluetooth adapter.

You didn't mention the model of adapter or I'd look at D-link for issues with the model.

.
0
 
B1DUDEAuthor Commented:
Purchased another identical adapter to check the hardware.  Either I purchased two bad dongles in a row or there is something else.  The second dongle didn't work either.
The install software installs some bluetooth control software then attempts to install the drivers.  About half way through the driver install period, a prompt says to "plug in the bluetooth adapter then click OK".  Plug in the adapter, click OK and wait.  After a couple of minutes go by the same prompt comes back.    It's like the install software never sees the hardware to assign the driver to.  The specs on the back of the package say the dongle is USB 1.1 compatible.  I doubt my laptop has an older version of the USB port control....is there a way to make sure?
0
 
B1DUDEAuthor Commented:
The adapter is the DBT-120 by the way.  Sorry I failed to mention that yet.
0
 
PCBONEZCommented:
>>>
I doubt my laptop has an older version of the USB port control.
<<<

The 4150 comes with a USB 1.1 port.
You have a USB 1.1 device 'compatible' device so it should work fine.
You will be limited to a max USB speed of 12 Mb/sec is all that means.

http://www.dellcommunity.com/supportforums/board/message?board.id=insp_general&message.id=134780&c=us&l=en&cs=&s=gen

It might be a problem in the future if you wan't to use an attached USB 2.x device at full speed. (Make sure anything you get for it says backwards compatible to USB 1.1.)

.
0
 
B1DUDEAuthor Commented:
Some more trouble shooting info from this past week.
In review:
1.  Tried installing two different adapters (same model) to rule out hardware failures.  Both had the same hangup during install.
2.  Next tried installing the first hardware device I purchased on a newer laptop I use from work.  The install went perfectly and only took about 8 min.  That laptop was a newer Dell D610.  I would have stopped there, but installing "unapproved" hardware/software on my work machine is a nono so I uninstalled the hw/sw as soon as the experiment had served it's purpose.
Way ahead:
One thing I haven't tried is just letting windowsXP  have a go at the install and let xp choose the drivers.
I'll try that next.
Thanks all..I'll report back soon.
E

0
 
B1DUDEAuthor Commented:
Update.
Just turned off the laptop and let Mr. Gates pick the drivers and ignored the whole D-link install directions.

Everything appeared to work.

I managed to pair my Palm TE2 to the laptop....then ran into the last hitch which should probably be my next thread.  I haven't been able to turn on intenet connection sharing on the laptop...I get an error
"Sharing cannot be enabled.  A LAN connection is already configured with the IP address that is required for automatic IP addressing"

Thanks for the help.  

E
0
 
B1DUDEAuthor Commented:
Intended internet connection is still not functional.  However I am at least able to complete a pairing.  The accuracy/quality of the fix (albeit simple...just let windows do it) will be determined by the final capability achieved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.