Samba setup (Trixbox)

Hello,

I have installed Samba server on my trixbox using webmin. when I try to log from windows it asks me for username and password but for some reasons it don't give me access, Can some body help me to set the Samaba users.
I tryed with security set to SHARE and to USER nothing works.

# Samba config file created using SWAT
# from 192.168.2.2 (192.168.2.2)
# Date: 2008/01/20 18:09:38

[global]
      workgroup = MYGROUP
      server string = Samba Server Version %v
      encrypt passwords = No
      cups options = raw

[root]
      comment = Home Directories
      writable = yes
      path = /root
      username = admin

[printers]
      comment = All Printers
      path = /var/spool/samba
      printable = Yes
      browseable = No
S_WarriorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ibu1System AdministratorCommented:
Step by Step
1)In the file /etc/samba/smb.conf, verify that the following line does not exist:
encrypt passwords = no
OR
 To specifically enable encrypted passwords in the configuration file, add the following lines to etc/samba/smb.conf:
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

2)cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd
3)chmod 600 /etc/samba/smbpasswd
4)smbpasswd -a username


For more details refer this link
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/s1-samba-configuring.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
http:// thevpn.guruCommented:
As @Ibu1 said you have to add smbpasswd -a username to add users, you can also try public=yes guest=yes and SHARE
0
S_WarriorAuthor Commented:
Hi, I have done the following:
[global]
      workgroup = MYGROUP
      server string = Samba Server Version %v
      security = SHARE
      password server = 123
      ldap ssl = no
      guest ok = Yes
      cups options = raw
      encrypt passwords = no
      

[root]
      comment = Home Directories
      path = /root
      valid users = root
      read only = No
      acl check permissions = No
        public=yes
      guest=yes


I can see the root share but when I try to access it it asks for username & password.
I tryed to run smbpasswd -a root changed the password and still it do not give me access...
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ibu1System AdministratorCommented:
U did the above mentioned steps or not ?
And one more thing is that the
encrypt passwords = yes
0
S_WarriorAuthor Commented:
I have changed the link to encrypt passwords = yes restarted Samaba and still no aceess.

Can you contact me by MSN I can give u SSH access
0
S_WarriorAuthor Commented:
My MSN: sales (at) mekashron (dot) com
0
ibu1System AdministratorCommented:
This is blocked in my company.
;(

u did this
cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd
0
ibu1System AdministratorCommented:
What if u try
security = user
0
S_WarriorAuthor Commented:
yes I did. if I try security = user it request password right away.

MSN blocked or SSH?
0
pkhera_2001Commented:
Hi!

These are the minimum required steps I follow on my linux box:
I keep default smb.conf file
issue following commands(while logged in as root or su -)
#service smb start
#smbpasswd -a root
(twice assign the password)
Now on windows machine simply map a network drive by using username root and password assigned with smpasswd -a command. (if you need to provide smb access to other users then user their name with smbpasswd comamnd, -a option is used to add new samba user and assign him a samba password).

If can log in to yahoo messnger then I may be help you only, my ID is smartrealtalks@yahoo.com
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.