What is peculiar with Websphere Studio 6 on jsp:usebean?

I moved a clean project from Websphere Studio version 5.1 to version 6.0 using export/import ear.  On version 6.0, it flagged the line <jsp:useBean id="abean" class="com.packages.Abean"/> with an error 'package com.packages' does not exists.  This is not flagged as an error in Websphere studio 5 and works fine.  Do you have any idea what's peculiar with Websphere studio 6 (new name is Rational 6)?
royrubioAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
CEHJCommented:
That would indicate that Abean is no longer in the classpath
0
 
royrubioAuthor Commented:
The solution on the IBM site covers the server config migration, not related to the compilation issue that I have.  I did it anyway, but the jsp:usebean was still being flagged: 'package com.packages does not exists'.  I tried to put AbeanX which does not exists and I got a second error saying that the class class AbeanX does not exists.  So this proves that the com.packages.Abean is visible.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
royrubioAuthor Commented:
The link given covers JMS, not related to my problem.  

Anyway, I figured out a work-around to my problem, not an elegant solution though.  I created a web project in RAD6 then imported (from file system) all the java sources, JSPs, js files, images, struts and tiles configs, and defined the datasource for the database.  Nothing was flagged as error and the application run without errors.

I'm splitting the points to the 2 people for their time and effort.  At least they stirred my mind into thinking more.  Thanks guys.
0
 
royrubioAuthor Commented:
Thanks krakatoa and CEHJ.  Though none of your solutions solved the problem, they helped me think of other alternatives to solve the problem.  Your assistance is appreciated.
0
 
krakatoaCommented:
k.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.