Unable to dual boot from Oracle Unbreakable Linux to Windows partition.

I have installed Oracle Unbreakable Linux, which is based on Fedora Ver4.

I am not able to boot to windows partition though everything looks perfect.

************
grub.conf
contains correct entries
************
default=0
timeout=5
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Enterprise (2.6.9-42.0.0.0.1.EL)
        root (hd0,5)
        kernel /vmlinuz-2.6.9-42.0.0.0.1.EL ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.9-42.0.0.0.1.EL.img
title Microsoft Windows
        rootnoverify (hd0,0)
        chainloader +1

************
/etc/fstab
shows /dev/hda1 mapped to /mnt/win (defaults or auto,users,rw options don't work)
************
[root@pc ~]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
/dev/hda1               /mnt/win                vfat    auto,users,rw        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
/dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,managed 0 0

**********
even tried to mount manually, but failed
**********
[root@pc ~]# mount -t vfat /dev/hda1 /mnt/win
mount: /dev/hda1 already mounted or /mnt/win busy
mount: according to mtab, /dev/hda1 is already mounted on /mnt/win

**********
Tried to create my own entry. Created a directory disc and tried to mount it with /dev/hda1. disc shows no files.
**********
[root@pc ~]# mkdir diskc
[root@pc ~]# mount -t vfat /dev/hda1 ./diskc
[root@pc ~]# ls -l diskc
total 0

Please help
gram77Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

http:// thevpn.guruCommented:
[root@pc ~]# mount -t vfat /dev/hda1 /mnt/win
mount: /dev/hda1 already mounted or /mnt/win busy
mount: according to mtab, /dev/hda1 is already mounted on /mnt/win


cd /mnt/win

does it contain your windows files ?

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gram77Author Commented:
yes
0
http:// thevpn.guruCommented:
I think you got soemthing wrong here...

Do you want to access your windows files ..or do you want to boot into Windows ?

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

gram77Author Commented:
both actually.

I want to boot into windows and also access windows files from Linux.

Secondly, in grub.conf hiddenmenu is uncommented, yet the menu for dual booting is not displayed until I press enter. Strange isn't it?
0
http:// thevpn.guruCommented:
Well about accessing your files in linux you said that your windows files are in
/mnt/win
so in other words your windows files are accessible in linux through this dir..

As for your GRUB file

Try something like

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title           Windows NT/2000/XP (loader)
root            (hd0,0)
savedefault
makeactive
chainloader     +1


http://www.faqs.org/docs/Linux-mini/Multiboot-with-GRUB.html
http://www.geocities.com/epark/linux/grub-w2k-HOWTO.html

0
gram77Author Commented:
shakoush2001:
This didn't work either:
# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title           Windows NT/2000/XP (loader)
root            (hd0,0)
savedefault
makeactive
chainloader     +1
0
http:// thevpn.guruCommented:
Oh wait sorry

hiddenmenu should be

#hiddenmenu

otherwise you need to press ESC to see the menu
0
gram77Author Commented:
# fsck /dev/hda1
fsck 1.35 (28-Feb-2004)
dosfsck 2.8, 28 Feb 2001, FAT32, LFN
Warning: FAT32 support is still ALPHA.
/dev/hda1: 0 files, 1/1278924 clusters

There are no files in that partition. It has been wiped out. It is pinging for the windows partition

Rather than simply setting the partition type, I checked on formatting /dev/hda1 That is when the files disappeared.

0
gram77Author Commented:
This is what I got from forums.oracle.com:

Bad news. Maybe /dev/hda1 isn't there any more? Try this:

Using your Linux install media, when you get to the "boot:" prompt type:

boot: linux rescue

and just have Anaconda skip mounting your hard drive on "/mnt/sysimage".

Once you get to the shell prompt, try this:

# fsck -f /dev/hda1

to see if there is still a recognizable file system on "/dev/hda1".

You may find it more intuitive to use Knoppix, Fedora Live or some other live CD besides the linux rescue mode.

# fsck -f /dev/hda1
shows 0 files in it!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.