The USB device can perform faster if you connect it ti a Hi Speed USB 2.0

i keep getting a message that i am connecting a usb 2 device to usb 2 controllers, i thought my mobo has usb 2 because it was a newer mobo..can anyone give me a definite ansewr... if i have usb 2, why does device manager not indicate this and why am i getting this error

here is my mobo

asus p5gdc-v deluxe mobo
finnstoneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
You're right you should have USB 2.0 on that board.
If you have other deivces connected to the same hub try with those disconnected.

If you still get the error it may be a problem with a corrupt driver.  Go to device manager and delete the entries for the USB hubs (while there are no devices connected) and then reboot the computer so Windows will reload the drivers when it detects the hubs.
0
PCBONEZCommented:
You keep getting a message that you are connecting a usb 2 device to usb 2 controller?
-
Other than there is a message popping up confirming a correct connection what is the problem?
0
finnstoneAuthor Commented:
the problem is that my external cd drive is not running at a good enough speed so movies are really choppy when trying to watch them on my computer.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

MarkCommented:
The only time I've seen this happen, is in XP without service packs installed. The original XP was not released with USB 2.0 support but was included in subsequent service packs.
What OS are you running?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PCBONEZCommented:
First two things to do:
Install Service Pack 2.
Run Windows Update.
0
PCBONEZCommented:
Device Manager doesn't always 'say' - USB*2* even if it is.
It depends on the drivers and USB chips involved.
0
MarkCommented:
Usually in device manager, under the Universal Serial Bus controllers, if the USB host controller is identified with the word "ENHANCED" it is usb 2.0 (
USBFAQ-intro-2.gif
0
Gary CaseRetiredCommented:
To confirm that your system "knows" the USB ports are USB v2 ==> Go to Device Manager; expand the Universal Serial Bus controllers section (click the "+" sign); and see if the word "Enhanced" is included on any of the Host Controller lines.  (It won't show on all ... but just so you see "Enhanced" then the system supports USB v2).

If you don't see "Enhanced", then right-click on each of the Host Controller lines (there will be several) and "Uninstall" them all.   Then reboot.   This will force driver updates as they are reinstalled.   As long as you're running at least SP1 this will install USB 2 support [If you don't have any service packs installed, just install SP3 ==> available here:
http://www.microsoft.com/downloads/details.aspx?FamilyID=75ed934c-8423-4386-ad98-36b124a720aa&DisplayLang=en  (This is the Release Candidate ... not quite final (but it is essentially done and works just fine => I've tested it quite thoroughly).

"... external cd drive  ..." ==>  Do you mean DVD drive?
"... movies are really choppy ..." ==>   What format are the movies stored in?   Are these commercial DVDs?   Divx?  MPeg4?  etc.   ... also, are they also "choppy" if you watch them on your internal optical drive (if you have one) ??


0
nobusCommented:
if it was ok before, try a system restore to a previous date.
0
finnstoneAuthor Commented:
i had to enter startup and change bios settings. for some reason, usb2.0 was disabled. weird. thanks though!
0
MarkCommented:
I think you should have your points refunded as you have answered the question yourself.
http://www.experts-exchange.com/help.jsp#hi333
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.