VBScript: Remote Desktop Disconnected

I have a clients PC that gets the following error when trying to RDP to a temrinal server.  It is a Vista Home Premium that is able to connect to other RDP sessions.  They are not able to get to term2.dtacoremarketing.com.  The message:  
The remote computer disconnected the session because of an error in the liscensing protocol.  Please try connecting to the remote computer again or contact your server administrator.
Rob TimmermansIT SpecialistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William ElliottSr Tech GuruCommented:
here are a list of troubleshooting steps that should help you diagnose the issue.
http://technet2.microsoft.com/windowsserver/en/library/d5336104-c7c3-4a6c-84a6-ef6eaecd80771033.mspx?mfr=true
0
Rob TimmermansIT SpecialistAuthor Commented:
None of those solutions work.  I should also note that the terminal server the client is connecting to is Windows 2000 Server.  I myself can connect to it from a variety of machines, just not the clients.
0
William ElliottSr Tech GuruCommented:
i can't get to it either...

have they tried with the ipaddress instead of the name? does it work?
what results do youget from the troubleshooting?
what steps have you taken?

i need more input in order to get a good solution


At the command prompt, run the ping command from each computer to each computer by using:
" Fully qualified domain name (for example, term2.dtacoremarketing.com)
" NetBIOS name (dtacoremarketing.com)
" The IP address (for example, 206.73.118.1)
 
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

William ElliottSr Tech GuruCommented:
chances are their firewall is preventing them from getting out to it.
0
Rob TimmermansIT SpecialistAuthor Commented:
You can't ping it from any PC.  I can get to the address fine from my laptop and even my pocket pc.  I have tried the straight IP, same problem.
0
William ElliottSr Tech GuruCommented:
term2.dtacoremarketing.com doesn't work, but
term2.datacoremarketing.com does, as does
216.58.252.113


Pinging term2.datacoremarketing.com [216.58.252.113] with 32 bytes of data:

0
Rob TimmermansIT SpecialistAuthor Commented:
sorry.  I didn't realize I typed it in wrong in the question. term2.datacoremarketing.com is the correct address that will not work on the clients workstation.
0
Rob TimmermansIT SpecialistAuthor Commented:
Things I have tried on the workstation in question.  Disable all anti-virus, anti-spyware and firewall applications.  Updated drivers for NICs.  Removed and re-added the terminal liscence key in the registry.  Connected to a different IPS and router.
0
William ElliottSr Tech GuruCommented:
from here
http://support.microsoft.com/kb/187614

If you delete the HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing subkey on a client that is running Windows Vista or a later version, later attempts to connect to a Terminal Server may fail. Also, you receive the following error message:

An Error occurred in the Licensing Protocol

To resolve this problem, right-click the Remote Desktop Connection shortcut, and then click Run as Administrator. By default, the remote desktop connection runs as a user with the lowest user permissions. By default, a restricted user does not have permission to write registry entries to HKEY_LOCAL_MACHINE. Therefore, attempts to rewrite the MSLicensing key fail. Starting Remote Desktop Connection with administrative credentials provides the permissions that are necessary to write the needed registry keys.

--------------------------------------------------------------------------------
0
Rob TimmermansIT SpecialistAuthor Commented:
I did try that one.  It did not work.
0
William ElliottSr Tech GuruCommented:
even running it as the local administrator?

If you are using the 'new style' Start Menu inside Vista, the easiest way to launch an RDP session with administrator rights is to type into the Start Search field: mstsc
Then, hold down [Ctrl] and [Shift] and then press the [Enter] key. This will launch mstsc (the RDP client) with elevated rights.



look here
http://ts.veranoest.net/ts_logon.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob TimmermansIT SpecialistAuthor Commented:
Even that fails.  Let me add one more tidbit.  The client has 2 PC's with this problem. One a Vista notebook and the other a XP Pro desktop.  The problem began after they had "Geeks on Call' come and setup netork sharing between their PC's.
0
Rob TimmermansIT SpecialistAuthor Commented:
Thanks for the last article.  That worked.  I removed the MS Liscensing keys, then ran rdp as admin and it worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.