Remote connection trough VPN not working

HI there, I have two SQL 2005 instance, one on a laptop, let's call it GBE and another on VM. Each of these laptop have a second network interface created with OPenVPN to isolate them in a nice ans cozy VPN. Both are running XP Pro btw.

The laptop GBE has a named instance of 2005 since there is a instance of SQL2000 already on it. My problem is, none of these to can connect to each others database.
 I have a third machine wich has a clean install on Windows 2k3, also part of the VPN, on wich there is also a sql2005 default instance, to wich everyone can connect.

How can one remotely connect to a SQL2005 instance without having the dreaded 'remote connection not set' error ?
TCP/IP connection are turned on in each Surface area configuration ... is sql2000 interfering with sql2005 on the gbe laptop ? If yes what can i do.

Some pointers:
There are no firewalls activated
MSDTC is configured to permit everything
Averything is connected in a VPN while being a member of it's own network  ( 2 Network interface )


I post this question out of despair, having tried so many config that i'm starting from scratch, and hopefully, some help from friendly experts.

Regards
LVL 1
David MacDonaldChargé de projet processus d’affaires et systèmes TIAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VganCommented:
To connect to a SQL 2005 named instance you must also have SQL Server Browser running and active.

You get to that through SQL Server Configuration Manager /  SQL Server 2005 Services.   If it isn't running then start it.  If it is running make sure it is active by right clicking and selecting properties.  Then go to the Advanced tab and make sure Active is set to "YES".  If you have to start the service then you might want to change it to automatic start.  If you have to change any settings then you may have to reboot the computer as all too often, restarting the SQL server engine alone isn't enough, even when it indicates that is all that is needed.

You may also have to set up an alias on each client using the Run - cliconfg.exe program.  sometimes setting up the Aliases on the the server are enough but named instances are a lot more complicated than default instances.

Good Luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David MacDonaldChargé de projet processus d’affaires et systèmes TIAuthor Commented:
Hi VGan,
          i finally had figured it out by myself and had forgotten to delete the question. I needed in fact to reboot the machines after activated SQLBrowser. I also had messed up the listening comm. ports  of SQLBrowser by testing for a solution, I put them back to automatic configuration.

I'll award you the points since no one answered this, and you tipped me with the aliases, wich i did'nt really know about.

Regards !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.