Cannot share Program Files on Windows Vista - ACCESS DENIED!

I have set up a network with 2 vista computers over a wireless network. I can access the public folders and any other files that i share in the User's Folder. I however need to share a specialized framing software program which is located in Program Files.

I have shared this folder called "Framing Software" under the directory "Program Files" and set the user group Everyone to have full access and control. Then when I try to access the folder from the other Vista computer I can not access it.

I can not access any folder in the C Drive either, I can however access any other folder shared under the Users Folder eg Documents, Desktop etc. But the program cannot run from this location.

This problem happens on both computers. There must be some setting I am overlooking, It can not be impossible - Please help!
LVL 2
crnzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian PiercePhotographerCommented:
This is by design. If youy want to chnage this you will need to change the NTFS security of the folder. Right click on the folder, select "Properties" then "Security"
and add the users to the ACL and grant them the necessary permisions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
crnzAuthor Commented:
Hey KCTS,

I have tried your suggestion. When I add try to add the user to the folder, there is no option to add users from different computers on the network. Under the permissions part, I have added "Everyone" - but I still cannot access this folder.

I am going to try adding the "Guest" account to the ACL and give it full control. Hopefully this will work - but I am open to other suggestions at this stage.
0
crnzAuthor Commented:
Adding "Guest" to the ACL using KCTS's method worked.

Thanks a lot.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.