[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

DCOM server timeout and RPC server unavailable following virus cleaning.

Posted on 2008-02-11
5
Medium Priority
?
3,129 Views
Last Modified: 2010-07-27
The system is a home computer, Dell Optiplex GX110, 866 MHz, 512 MRam, XP Pro w/SP2. It is part of a home workgroup and shares out it's printer and an external USB Drive to a Laptop connected wirelessly. This system is connected via network cable to a DSL Gateway. This config has worked flawlessly for almost a year. Personal sidenote: This system belongs to my daughter who has multiple disabilities. It has a great deal of software and educational games that has been provided by friends and family. This system is her "lifeline" so to speak, and makes her feel 'good'. It allows her to interact with friends and help her to learn. She is terribly afraid of losing this system. Because of this, I am desperately trying to fix it for her and not have to do a re-install or repair install for fear of losing everything. I would not be able to replace even half of all the software. The only true "App" I have is Office XP Pro, fully licensed and registered.

Approximately 2 weeks ago, Norton Systemworks reported a virus, identifying the file as Fuwarxyus.dll and located in C:\windows\media. Norton could not remove or quarantine it. After some research, I found that it was the win32 Delf (sp?) virus. I further found that Avast Antivirus could handle it. Norton was due to expire in less than a month so I un-installed it and installed the free version of Avast. It detected and quarantined/removed the offending files. After a re-boot, the first problem presented itself as a long delay at startup. Welcome screen-long delay. Wallpaper-long delay. Desktop icons-long delay, etc. Try to open a folder - long delay. After trying various things, I looked at the event viewer and found the error listed above about DCOM. Timing the delays showed that it was 2 minutes. Exactly the timeout of the DCOM Process Launcher. I set the DCOM Launcher service to manually instead of Automatic and the system booted normally. Opened Office XP Word and received a warning that Word could not link to any external documents. I started to try other system level functions such as Defrag, un-install, etc. None would work. Research showed that this was because of an RPC (Remote procedure Call) problem. Looked in services, went to RPC, and when I clicked on Dependencies, it reported that the RPC server was unavailable. I don't know what happened. Whether it was the virus or a bad un-install of Norton. I cannot install anything that uses the Microsoft Installer or do many other system functions. I don't know if it is because DCOM is not starting and RPC needs it or what. I compared registry entries between this system and the Laptop (running XP Home w/sp2) and they appear the same. Otherwise, the system works great. The printer share, external folder shares, networking, etc. The workgroup stuff is all fine. I really need help to help my daughter keep her system intact. I have exhausted all my efforts. Everything I have found talks about servers. There is no server here... is there? No email account has ever been setup on this system as my daughter could not understand a "good" versus a "bad" email. I need help everyone... please.

Summary: DCOM Process Launcher will not start. RPC Server is Unavailable. Is one tied to the other?

I apologize for the length, but I needed to let everyone know where I am coming from on this and how important it is to me. Thanks to all of you for your help.
0
Comment
Question by:flubbster
  • 3
  • 2
5 Comments
 
LVL 6

Expert Comment

by:psyclown-
ID: 20865757
Hello flubbster,

Have you tried starting up in failsafe mode, and see if you get the same problem?
If not then maybe try and run a virus/spyware scan from there.

Best Regards,
psyclown
0
 
LVL 30

Author Comment

by:flubbster
ID: 20866059
I have not tried safe mode yet. I will try it tonight. If I start in safe mode, can I still access services and attempt to start DCOM? I will try it anyway and see what happens.
0
 
LVL 6

Expert Comment

by:psyclown-
ID: 20866072
Yea, that should still be functional in failsafe mode.
0
 
LVL 30

Author Comment

by:flubbster
ID: 20946532
Hello. Sorry it took a while, but I have been sick with the flu and am just getting back on my feet. Nasty bug!! Anyway, I tried safe mode and it did the same thing. I did some more research into this problem and I may have a solution. I will be trying it shortly and will report back as soon as possible.
0
 
LVL 30

Accepted Solution

by:
flubbster earned 0 total points
ID: 20948991
Greetings. I solved my problem. A ton of research kept leading to the same type of problem, always in reference to a windows 2003 server setup. I finally found an obscure reference to an XP Pro problem of a similar nature. Essentially, it involved the permissions on the registry hive. Specifically, HKEY_ROOT\CLSID. I added the following permissions to that key and made it applicable to all subkeys:

Authorized User: Read Only
Network Services: Full Control

Once I did this, I reset the DCOM Process Launcher to Automatic and re-booted. A look at services showed that it started. I then looked at RPC Service and it's dependencies. All dependencies were reported properly and the server was available. No more errors with linking in Microsoft Word and the installer is now working. Everything is back to normal.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you build your web application in Visual Studio you'll get at least a few binaries, or .DLL, files in your bin folder. However, there is more compiling to be done. Normally this would happen when an ASP.NET resource within the web site is request…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Stellar Phoenix SQL Database Repair software easily fixes the suspect mode issue of SQL Server database. It is a simple process to bring the database from suspect mode to normal mode. Check out the video and fix the SQL database suspect mode problem.
Suggested Courses

640 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question