Backup Exec Tape Catalog Fails

I am trying to restore some data from a 4 and a half year old LTO backup tape that was backed up using either Backupexec 8 or backup exec 9. The server I am using is windows 2003 sp2 with backup exec 11d.

The catalog job fails with the following error
Catalog- \\Servername2\drive
An inconsistency was encountered on the storage media in Q1.
V-79-57344-33994 - The data being read from the media is inconsistent.

If I rerun the catalog the same error occurs.

From looking at the catalog job log the tape contains several server's backups and the server (server 1) that I want to restore is listed as succesfully completed but the server that it fails on is the next item on the tape.

When I try to restore from this tape I can see server 1 that I need to restore and the different drives in the selection list. If I expand any of the drives I can see the backup with the correct date but when I click on this date backup exec freezes and crashes.

Any ideas as to how I can get the catalog to work correctly so I can restore this data?
LVL 1
matthewsj11Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Redwulf__53Commented:
Tapes from BE <10 normally can also be used by the built-in Windows NT Backup utility. So you should be able to check if the tape is corrupt by loading it with NT Backup (you'll need to stop the BE Media service to release the tapedrive, otherwise NT Backup won't see the LTO drive).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
matthewsj11Author Commented:
Is there anything else I need to do apart from stopping the backup exec services to get my tape drives to be visible under NT backup. I have stopped all the services but nothing is visible in the NT_backup.

I have 8 slot LTO2 autoloaders with one drive if this makes any difference.
0
Redwulf__53Commented:
Is the Removable Storage service started?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

matthewsj11Author Commented:
Yes the Removable Storage service is running.
0
Redwulf__53Commented:
Strange, it has worked for me every time... maybe a restart of the Removable Storage service.
Otherwise, I wouldn't know.
With regards to your original question: I do honestly think your tape is likely to have died.... I was trying this work-around to confirm this. BE11d should have no problem reading the tape if it was OK, even if it is from an antique version of BE.
I hope some other experts have additional suggestions.
0
matthewsj11Author Commented:
Thanks for your help.

I opened up the Removable Storage MMC and all the drives on this server are marked as offline. I disabled all the BE services and rebooted to no affect. Restarting all the backup exec services and the drives are online and working in Backup exec.

I don't want to change too many things on this server as our live backups will need to run in a few hours time.


0
Ron MalmsteadInformation Services ManagerCommented:
Yes, this used to plague me all the time...finally figured it out...

you need to go into BE > options>Catalog>, and change the option to "storage-media based catalogs"...this way it will catalog the tape based on the tape, not the BE database.

Inventory, then catalog the tape after you change that option.....  restore what you need...then change the option back to the way it was when you are done.


good luck...
0
matthewsj11Author Commented:
I finally solved this problem by using NT backup to restore the data. Inorder for NT backup to see the tape drives I disabled all the Backup Exec services. Uninstalled the tape drives and rebooted.

After reboot I installed the OEM drivers and restarted again.

This allowed NT Backup to view the tape drives and catalog the tapes. It could not see any of the Backup Exec agent backups but I managed to recover the required data from the flat file backups.

thanks for all your help.
0
Redwulf__53Commented:
Makes me feel a bit guilty about accepting the points.... I guess in the cases where I used this method, the BackupExec tape drivers were not installed....
Thanks for completing the information and I'm glad you're sorted! :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.