Vsftpd "put" verbosity

Hi I switched from wuftpd to vsftpd and now notice when I do a "put" it does not show the file name  included with the "150" respose code. This creates some issues for the various entities that connect to my server - depending on how they have scripted their transfers.
Is there a way to show more info with 150 response code after a "put"?

For exmple, here is the old (wuftpd) 150 get response (which I like):
ftp> put snapshot.log
local: snapshot.log remote: snapshot.log
227 Entering Passive Mode (192,168,99,4,225,208)
150 Opening BINARY mode data connection for snapshot.log.
226 Transfer complete.
22424 bytes sent in 0.000705 secs (3.1e+04 Kbytes/sec)

And Here is the new (vsftpd)
ftp> put snapshot.log
local: snapshot.log remote: snapshot.log
227 Entering Passive Mode (192,168,99,1,203,53)
150 Ok to send data.  <--- no file name !!!
226 File receive OK.
21848 bytes sent in 3.8e-05 secs (5.6e+05 Kbytes/sec)
ftp>
medentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mjutrasCommented:
if you're ok with logs you could enable the following option in your server:

log_ftp_protocol
    When enabled, all FTP requests and responses are logged, providing the option xferlog_std_format is not enabled. Useful for debugging.

    Default: NO
0
medentAuthor Commented:
Thanks but I do not need more logging on my end, just the the ftp clients who are connecting to me want the "150" message changes back to the way it was...

ie.
150 Opening BINARY mode data connection for snapshot.log.


0
mjutrasCommented:
In fact it really depend on the ftp server you are using, some are adding more detailed messages.

This is coded in the ftp server itself so if you want to have the filename shown in the 150 message you will have to change the source code of your ftp server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.