Public Folder tree not visible in Exchange System Manager

Hi ,

For some reason I do not see any public folders listed under Folders -> Public Folders ( which is the default , MAPI tree ).

They do exist and they are accessible from Outlook.

Although I have full admin rights on the organization, when I go to any given folder properties in Public Folder Store - > Public Folders , under permissions I have only "Client permissions available " - the other 2 buttons namely "Directory rights" and " Administrative rights", are grayed out. When I click on "Client permissions available " I get an error pop-up message :

Title : Exchange System manager
Text : An unexpected error occurred
ID no: 8000ffff
Exchange System manager

If I click on the same button , but holding Ctrl key I get another pop-up error :

Title : Exchange System manager
Text : Unable to read security information
from the directory
ID no: c1033028
Exchange System manager

I tried the same with another admin account - same result.

It seems that this has been an issue since the installation of that Exchange 2003 server.
I can guess that this has something to do with the Exchange integration with the AD and the set permissions.

Any help is greatly appreciated !
filipneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kind4meCommented:
http://support.microsoft.com/default.aspx?kbid=317180

To resolve this issue, move the public folder Active Directory objects back to their default organizational unit, which is the Microsoft Exchange System Objects organizational unit.
0
filipneAuthor Commented:
Thanks kind4me !
Tried that to no avail.
The thing is that I can see only a few public folders in Microsoft Exchange System Objectsusing ADSI.
All of them are mail enabled. The rest of the folders are not showing up in ADSI. I am not sure wether they are there at all, because ADSI does not really have a way to search in it.

In addition, I  created a test folder under Public Folders in Exchange System manager and it disappeared from there right away.
Yet anathor thing is that when iI got to the properties of anay of the public folders from Outlook and click on
Summary a I get "The Summary tab could nor be displayed. The client operation failed" error message.

Any help is appreciated !
0
filipneAuthor Commented:
Here is the  solution :

Here is what was causing this issue:

Sharepoint server was installed on the same Windows Server. Thus Sharepoint and Exchange were sharing the same Default web page in IIS.

Since Exchange virtual directories were not excluded from the sharepoint path in IIS , every time Exchange was trying to access them (either to display public folders in ESM or everything else dependant on IIS ) what actually was happening is that Sharpoint was trying to validate access credentials against its own access database and since , of course there was nothing exchange related there , it was issuing errors described in my original post.

For Sharepoint and Exchane to co-exist some additional steps must be taken.

Details in :

http://office.microsoft.com/en-us/help/HA011607771033.aspx

After performing steps described in the Sharepoint section , public folders re-appeared in ESM.

After that I had some other issues resolved by following
http://support.microsoft.com/kb/270905

Hope this will help someone else !
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.