SMTPDiag Expected "250" error

This one is driving me crazy.  I'm not sure when this problem started.  We have 2 ISPs, Earthlink's T1 service and a local broadband provider.  I receive the same error through both ISPs, which leads me to believe it's some type of reverse DNS problem.  However, I do have valid Reverse DNS entries setup for both ISPs ...  A reverse DNS lookup on both my IPs resolves correctly.

The error I get is this:
Error: Expected "250".  Server rejected the recipient address.  Failed to submit mail to

The email address we're trying to send to is another domain, not surewest, so I'm guessing Surewest is their ISP and they host their own server on the Surewest network.

The mail doesn't bounce back and doesn't make it to the recipient.  In the past, these emails have bounced back weeks or months later.  Our Exchange is set to deliver NDRs if messages are delivered in 3 minutes, so something weird is happening.

I contacted Surewest, and they pretty much told me to call my ISP.

As a test, I just tried an SMTPdiag to domain, and I am also getting a failure:
Error: Expected "220". Server is not accepting connections. Failed to submit mail to

Any help is much appreciated!  Thanks.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OK, lets try and emulate what SMTPDiag is doing to figure out what is going on.

On the Exchange server, Start > Run > telnet 25 > then issue commands as follows, and let us know where you get stuck;

subject:this is a test
whatever, blah blah blah

I expect that you are either on a bad IP, have a poor PTR record or an incorrect SMTP greeting - so you could check that out too by putting your domain into ->

BigFunkyChiefAuthor Commented:
Thanks for the reply.  Actually the Yahoo eventually went through, and my main concern is the surewest issue, so here's what happens when >> telnet

220 ESMTP Mirapoint 3.8.4-GA; Mon, 1 Feb 2008
EHLO Hello [] (may be forged), pleased to meet you
250-SIZE 31457280
250 HELP
mail from:
250 ok
rcpt to:
550 denied

That looks like a recipient problem

Try putting the recipient email address here and seeing if you get the same problem ->


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

BigFunkyChiefAuthor Commented:
Yup, same thing:
 550 <>... Relaying denied

Something WRONG!! rc=550
Then it is a recipient problem - nothing to do with you.

Do you have any other problem domains?
BigFunkyChiefAuthor Commented:
I just called the client, of course they think everything is working great.  I had her send me a test email, and it came through, I replied and she got it, and replied back confirming.

My issue is my boss has been sending emails to this company and the guy doesn't receive them at all.  I had other issues sending to Surewest, so thought the SMTPDiag was showing me a problem going to that domain.  Now I wonder.  But if I can send mail to the user, shouldn't SMTPDiag show successful, at least occassionaly?
Yes it should show successful, but I am wondering - if a reply works, can you confirm that you are entering her address correctly?
BigFunkyChiefAuthor Commented:
Regarding other problem domains, there was one other one that my boss mentioned. I'll need to get it and test.

DNSReports tells me:
[ERROR: A CNAME appeared in the MX records; this is not valid (per RFCs 974 "Minor Special Issues" section, and 1034 section 3.6.2.
          Mailservers are not required to send E-mail to]
That dnsreport error is just telling you to remove the CNAME from the MX records - it is a minor error.  Something that should be fixed, but not a deal breaker.
BigFunkyChiefAuthor Commented:
Weird.  Now everything passes, no problem!  I have no idea why it's now working..I have not changed anything.  Anyways, thanks for all the help, points awarded.
I expect it was a problem on their end, and they resolved it and covered it up - that is just a wild guess though
BigFunkyChiefAuthor Commented:
And from the remote site, it now passes occassionally, and then gives an 451 Requested mail action not taken: mailbox unavailable error.  Strange.  Thanks again for the help.
451 is a temp error, usually meaning they are using greylisting.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.