logon server is set to host machine name, not domain. How do I fix this?

We are having problems with our web filter, they told us that the host machine is not properly connected to the domain.  From command prompt I ran set logonserver and it came back logonserver\\10-adm-2468 (my machine name).
I read another post on this site that said to enter Set logonserver=domain controller, which I did and It appeared to work until I restarted my machine then it when back to logonserver\\10-adm-2468.  I have removed my machine from the domain and added back, changed computer name, static and dhcp, none of then successful.  I am not, to my knowledge, experiencing any other network related issues, other than logonserver being incorrect.  Any information is greatly appreciated.

Thank you,
Jonny
BISDAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SteveH_UKCommented:
The logonserver will be incorrect when one of the following apply:

1)  The local server is a domain controller
2)  A domain controller was unavailable and the user was logged on using cached credentials

I'm assuming (1) is not applicable here.

In that case, I'd recommend you use the NETDIAG tool from Microsoft's website.  This will detect problems contacting Active Directory, most likely due to DNS issues.  Also check that the computer's clock is within 5 minutes of a domain controller, otherwise network logons will fail.  See my blog entry http://blogs.bdnet.co.uk/steve/archive/2008/01/06/The-Windows-Time-Service.aspx for more on time synchronisation.

NETDIAG can be accessed here: http://www.microsoft.com/downloads/details.aspx?familyid=6EC50B78-8BE1-4E81-B3BE-4E7AC4F0912D&displaylang=en

Let me know if you need further assistance.
0
BISDAuthor Commented:
I believe your second statement to be correct.  I have been told that i am logging in with cached credentials.  I ran netdiag(already installed on both of my DC's) and everything passed.  I have verified my time to be in sync with the DC's (set my pc to dc using nettime).  Not sure if it helps, but I am running Vista, DC's are win2003, in 6-7000 client environment across a flat network.  To my knowledge I am the only person experiencing this problem
Any other suggestions greatly appreciated,
Jonny
0
SteveH_UKCommented:
First off, you need to run the NETDIAG tool on the Vista machine, as it is the Vista machine that is having problems with network communication.

Also:

1.  Are you using a wireless network to logon?
2.  Is the Vista firewall enabled?
3.  Are other users using Vista?
4.  Are you using WINS?
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

SteveH_UKCommented:
Also, does this resource help?

http://support.microsoft.com/kb/927551 (Vista network diagnostics webcast)
0
BISDAuthor Commented:
OK, I ran NetDiag on my machine (output attached) and it found a few problems, although they don't mean a lot to me.  Can you help me figure out what I need to do next.


1.  Are you using a wireless network to logon? no
2.  Is the Vista firewall enabled? yes, but I have also tried it with firewall disabled.
3.  Are other users using Vista? yes, they are not expiriencing this problem
4.  Are you using WINS? no

Thanks
NetDiagOutput.txt
0
SteveH_UKCommented:
OK.  Thanks for that, very informative.

The first thing I'd do is disable all the unnecessary network interfaces.  At the moment you have two active connections {A4573F2E-79AE-4D8D-9C78-B0C0B7BED367} and "Local Area Connection".  I'd make sure that all connections except "Local Area Connection" are disabled.  The reason is that the order of interfaces can be important and the easiest way to test around that problem is by disabling unnecessary interfaces.  It matters what is available when the computer starts.

You may also be affected by what seems to be static DNS server configuration on your wireless connection.  I'm guessing that this is to allow domain server connection from external wireless networks.

If that still doesn't improve things (after a reboot).  There are two things I'd look at:

1.  Try moving the computer out of the domain and then rejoin.  There may be an issue with the computer account trust.
2.  Try Vista Service Pack 1 (released 4 Feb 2008): http://technet.microsoft.com/en-us/windowsvista/bb738089.aspx
0
BISDAuthor Commented:
I disabled all connections except LAN.  Removed machine from the domain and renamed my machine, then restarted and rejoined the domain.  Still no good.

With regards to your second paragraph; This is appears to be the DNS for my home network on the wireless NIC.  It is pointed to ComCast (my home ISP).  Our work connection is provided by AT&T.  Could this be a problem.  I rarely connect to our wireless connection while at work, although I have successfully since this problem arose, as I sit at my desk most of the time.
Do you think this could be the problem.  Again, I have disabled my Wireless connection, so I don't think it should affect my Ethernet NIC, but then you're the expert.  Let me know what you think.
We don't have a subscription to Technet, so I am unable to download SP1, but no one else running Vista here has SP1 either, and they are not having this issue.  
Again I thank you for your time and any advice you have for me.

Jonny
0
SteveH_UKCommented:
Are you attempting these processes over a VPN?

To log on using the domain you need to have the VPN established prior to the computer startup.  This can be done with 3rd party VPN software, but not using the standard Windows VPN connections.  Although the Windows VPN will log in to the network over the connection, the computer is unable to logon at boot.

I'd recommend that you reconnect to the servers while at work.  Then logon, still at work, and then try at home once the problems have been solved.

Also check that your VPN firewall is allowing your computer access to the domain DNS servers as that may also be the problem.
0
BISDAuthor Commented:
No, I am not using VPN
0
BISDAuthor Commented:
I found the solution on another site:
open regedit
search for logonserver
change value to domain controller
restart machine

thanks for your help
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SteveH_UKCommented:
I'm not convinced this is a real solution to your problem.  It looks to me like a short-lived hack.  I don't mind if you close the solution as I don't have any better suggestions at this point, but I really don't think it is a correct solution.

However, if it helps you for now then great.  Good luck in any case.

Steve
0
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.