Solaris OS does not see LUN's

I did a reconfigure  (reboot -- -r) on the Solaris box and now I dont see any devices related to the SAN.  
Before in /dev/rdsk there were several devices related to san.  Now there are only the 3 internal drives.
We use a Qlogic2300 HBA card.  WHen I run the Qlogic util, it can see all LUN's but the Solaris OS doesnt see them.  If I run format I only get

       0. c1t0d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
       1. c1t2d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
       2. c1t3d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
 This is what I should see:
       0. c1t0d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
       1. c1t3d0 <SUN72G cyl 14087 alt 2 hd 24 sec 424>
       2. c3t3d0 <XIOtech-Magnitude3D-1.00 cyl 52430 alt 2 hd 20 sec 100>
       3. c3t3d3 <XIOtech-Magnitude3D-3.00 cyl 65533 alt 2 hd 20 sec 160>

We also use vertias volume manager.  Let me know if you need any info from that.  but
I feel its the OS that needs to be configured.   Please advise

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

If you have copy of /etc/system, then compare it with the current one (you see the modification time of this file if it is after the reboot)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
esacadminAuthor Commented:
The sytstem file is identical.  Any other suggestions?
It could be that:

- You applied some patches that overwrite some system config files
- The HBA driver need re installation
- The connectivity between your SAN infrastructure is lost (cables, switches, etc)

Check if the /kernel/drv/sd.conf file is changed after the reconfig reboot
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
what does an
  cfgadm -al
show? Do you see the SAN devices (LUNs) there?
If not, try using
  cfgadm -o show_FCP_devs

Please post the output -- at least the part for your SAN adapter (Qlogic)
esacadminAuthor Commented:
 cfgadm -o show_FCP_devs
shows the following:

cfgadm: Configuration administration not supported
  I am told this is because I am using the Qlogic Drivers..
Did you "Check if the /kernel/drv/sd.conf file is changed after the reconfig reboot"?
esacadminAuthor Commented:

Feb 11 13:53:27 system1 scsi: [ID 193665] scg0 at mpt0: target 0 lun 0
Feb 11 13:53:27 system1 genunix: [ID 936769] scg0 is /pci@1f,700000/scsi@2/scg@0,0
Feb 11 13:53:27 system1 scsi: [ID 193665] scg1 at mpt1: target 0 lun 0
Feb 11 13:53:27 system1 genunix: [ID 936769] scg1 is /pci@1f,700000/scsi@2,1/scg@0,0
Feb 11 13:53:27 system1 scsi: [ID 193665] scg2 at qla23000: target 0 lun 0
Feb 11 13:53:27 system1 genunix: [ID 936769] scg2 is /pci@1c,600000/fibre-channel@1/scg@0,0
Feb 11 13:53:34 system1 ebus: [ID 521012] su0 at ebus0: offset 0,3f8
Feb 11 13:53:34 system1 genunix: [ID 936769] su0 is /pci@1e,600000/isa@7/serial@0,3f8
Feb 11 13:53:34 system1 ebus: [ID 521012] su1 at ebus0: offset 0,2e8
Feb 11 13:53:34 system1 genunix: [ID 936769] su1 is /pci@1e,600000/isa@7/serial@0,2e8
Feb 11 13:53:42 system1 pseudo: [ID 129642] pseudo-device: pm0
Feb 11 13:53:42 system1 genunix: [ID 936769] pm0 is /pseudo/pm@0
What was that :)
esacadminAuthor Commented:

it shows the fibrechannel card as being named scg2.  the previous admin thinks the device was renamed when I did the boot reconfigure and maybe thats why it cant see the san drives cuz it doesnt know the correct name of the device?  
OK, what do you have in sd.conf?
esacadminAuthor Commented:
here is sd.conf
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
1) You have a lot of duplicate entries in your file. Maybe, you want
    to clean up a little bit
2) You configured your Qlogic HBA to provide SCSI targets starting
    from ID 0.
    This ID is already in use by your system. Change it to somewhat
    higher (2048 or the like) and do a reconfigure boot ("boot -r" at
    OBP prompt or "touch /reconfigure; init 6"). This is a known issue,
    when using Veritas DMP
3) I've also seen a sd.conf with entries for Qlogic drivers looking like
    this. I've left off the usual entries (name="sd" class="scsi" ...)
    preceeding it:

# entries for Qlogic HBA with Qlogic drivers:
name="sd" parent="qla2300" target=0 lun=0;
name="sd" parent="qla2300" target=0 lun=1;
name="sd" parent="qla2300" target=0 lun=2;
name="sd" parent="qla2300" target=0 lun=3;
name="sd" parent="qla2300" target=0 lun=4;
name="sd" parent="qla2300" target=0 lun=5;
name="sd" parent="qla2300" target=0 lun=6;
name="sd" parent="qla2300" target=0 lun=7;
name="sd" parent="qla2300" target=1 lun=0;
name="sd" parent="qla2300" target=1 lun=1;
name="sd" parent="qla2300" target=1 lun=2;
name="sd" parent="qla2300" target=1 lun=3;
name="sd" parent="qla2300" target=1 lun=4;
name="sd" parent="qla2300" target=1 lun=5;
name="sd" parent="qla2300" target=1 lun=6;
name="sd" parent="qla2300" target=1 lun=7;
name="sd" parent="qla2300" target=2 lun=0;
name="sd" parent="qla2300" target=3 lun=0;
name="sd" parent="qla2300" target=4 lun=0;
name="sd" parent="qla2300" target=5 lun=0;
name="sd" parent="qla2300" target=6 lun=0;
name="sd" parent="qla2300" target=7 lun=0;
name="sd" parent="qla2300" target=8 lun=0;
name="sd" parent="qla2300" target=9 lun=0;
name="sd" parent="qla2300" target=10 lun=0;
name="sd" parent="qla2300" target=11 lun=0;
name="sd" parent="qla2300" target=12 lun=0;
name="sd" parent="qla2300" target=13 lun=0;
name="sd" parent="qla2300" target=14 lun=0;
name="sd" parent="qla2300" target=15 lun=0;
name="sd" parent="qla2300" target=16 lun=0;
name="sd" parent="qla2300" target=17 lun=0;
name="sd" parent="qla2300" target=17 lun=1;
name="sd" parent="qla2300" target=17 lun=2;
name="sd" parent="qla2300" target=17 lun=3;	

Open in new window

esacadminAuthor Commented:
I would buy your logic on the duplicate entries, but We have node 1 of the cluster with the exact same config file and its working.  I did make some progress.  I forgot I attached a scsi tape drive to the box. I have disconnected it and did a boot reconfigure.  now it accepts cfgadm -c configure c2.  
Here is output of cfgadm -al. I still dont see any SAN drives in format.  
bash-2.03# cfgadm -al
Ap_Id                          Type         Receptacle   Occupant     Condition
c0                             scsi-bus     connected    configured   unknown
c0::dsk/c0t0d0                 CD-ROM       connected    configured   unknown
c1                             scsi-bus     connected    configured   unknown
c1::/dev/scg1                  unknown      connected    configured   unknown
c1::dsk/c1t0d0                 disk         connected    configured   unknown
c1::dsk/c1t2d0                 disk         connected    configured   unknown
c1::dsk/c1t3d0                 disk         connected    configured   unknown
c1::sg/c1t0l0                  unknown      connected    configured   unknown
c1::sg/c1t0l1                  unknown      connected    configured   unknown
c1::sg/c1t0l2                  unknown      connected    configured   unknown
c1::sg/c1t0l3                  unknown      connected    configured   unknown
c1::sg/c1t0l4                  unknown      connected    configured   unknown
c1::sg/c1t0l5                  unknown      connected    configured   unknown
c1::sg/c1t0l6                  unknown      connected    configured   unknown
c1::sg/c1t0l7                  unknown      connected    configured   unknown
c1::sg/c1t1l0                  unknown      connected    configured   unknown
c1::sg/c1t1l1                  unknown      connected    configured   unknown
c1::sg/c1t1l2                  unknown      connected    configured   unknown
c1::sg/c1t1l3                  unknown      connected    configured   unknown
c1::sg/c1t1l4                  unknown      connected    configured   unknown
c1::sg/c1t1l5                  unknown      connected    configured   unknown
c1::sg/c1t1l6                  unknown      connected    configured   unknown
c1::sg/c1t1l7                  unknown      connected    configured   unknown
c1::sg/c1t2l0                  unknown      connected    configured   unknown
c1::sg/c1t2l1                  unknown      connected    configured   unknown
c1::sg/c1t2l2                  unknown      connected    configured   unknown
c1::sg/c1t2l3                  unknown      connected    configured   unknown
c1::sg/c1t2l4                  unknown      connected    configured   unknown
c1::sg/c1t2l5                  unknown      connected    configured   unknown
c1::sg/c1t2l6                  unknown      connected    configured   unknown
c1::sg/c1t2l7                  unknown      connected    configured   unknown
c1::sg/c1t3l0                  unknown      connected    configured   unknown
c1::sg/c1t3l1                  unknown      connected    configured   unknown
c1::sg/c1t3l2                  unknown      connected    configured   unknown
c1::sg/c1t3l3                  unknown      connected    configured   unknown
c1::sg/c1t3l4                  unknown      connected    configured   unknown
c1::sg/c1t3l5                  unknown      connected    configured   unknown
c1::sg/c1t3l6                  unknown      connected    configured   unknown
c1::sg/c1t3l7                  unknown      connected    configured   unknown
c1::sg/c1t4l0                  unknown      connected    configured   unknown
c1::sg/c1t4l1                  unknown      connected    configured   unknown
c1::sg/c1t4l2                  unknown      connected    configured   unknown
c1::sg/c1t4l3                  unknown      connected    configured   unknown
c1::sg/c1t4l4                  unknown      connected    configured   unknown
c1::sg/c1t4l5                  unknown      connected    configured   unknown
c1::sg/c1t4l6                  unknown      connected    configured   unknown
c1::sg/c1t4l7                  unknown      connected    configured   unknown
c1::sg/c1t5l0                  unknown      connected    configured   unknown
c1::sg/c1t5l1                  unknown      connected    configured   unknown
c1::sg/c1t5l2                  unknown      connected    configured   unknown
c1::sg/c1t5l3                  unknown      connected    configured   unknown
c1::sg/c1t5l4                  unknown      connected    configured   unknown
c1::sg/c1t5l5                  unknown      connected    configured   unknown
c1::sg/c1t5l6                  unknown      connected    configured   unknown
c1::sg/c1t5l7                  unknown      connected    configured   unknown
c1::sg/c1t6l0                  unknown      connected    configured   unknown
c1::sg/c1t6l1                  unknown      connected    configured   unknown
c1::sg/c1t6l2                  unknown      connected    configured   unknown
c1::sg/c1t6l3                  unknown      connected    configured   unknown
c1::sg/c1t6l4                  unknown      connected    configured   unknown
c1::sg/c1t6l5                  unknown      connected    configured   unknown
c1::sg/c1t6l6                  unknown      connected    configured   unknown
c1::sg/c1t6l7                  unknown      connected    configured   unknown
c2                             scsi-bus     connected    configured   unknown
c2::/dev/scg2                  unknown      connected    configured   unknown
c2::sg/c2t0l0                  unknown      connected    configured   unknown
c2::sg/c2t0l1                  unknown      connected    configured   unknown
c2::sg/c2t0l2                  unknown      connected    configured   unknown
c2::sg/c2t0l3                  unknown      connected    configured   unknown
c2::sg/c2t0l4                  unknown      connected    configured   unknown
c2::sg/c2t0l5                  unknown      connected    configured   unknown
c2::sg/c2t0l6                  unknown      connected    configured   unknown
c2::sg/c2t0l7                  unknown      connected    configured   unknown
c2::sg/c2t1l0                  unknown      connected    configured   unknown
c2::sg/c2t1l1                  unknown      connected    configured   unknown
c2::sg/c2t1l2                  unknown      connected    configured   unknown
c2::sg/c2t1l3                  unknown      connected    configured   unknown
c2::sg/c2t1l4                  unknown      connected    configured   unknown
c2::sg/c2t1l5                  unknown      connected    configured   unknown
c2::sg/c2t1l6                  unknown      connected    configured   unknown
c2::sg/c2t1l7                  unknown      connected    configured   unknown
c2::sg/c2t2l0                  unknown      connected    configured   unknown
c2::sg/c2t2l1                  unknown      connected    configured   unknown
c2::sg/c2t2l2                  unknown      connected    configured   unknown
c2::sg/c2t2l3                  unknown      connected    configured   unknown
c2::sg/c2t2l4                  unknown      connected    configured   unknown
c2::sg/c2t2l5                  unknown      connected    configured   unknown
c2::sg/c2t2l6                  unknown      connected    configured   unknown
c2::sg/c2t2l7                  unknown      connected    configured   unknown
c2::sg/c2t3l0                  unknown      connected    configured   unknown
c2::sg/c2t3l1                  unknown      connected    configured   unknown
c2::sg/c2t3l2                  unknown      connected    configured   unknown
c2::sg/c2t3l3                  unknown      connected    configured   unknown
c2::sg/c2t3l4                  unknown      connected    configured   unknown
c2::sg/c2t3l5                  unknown      connected    configured   unknown
c2::sg/c2t3l6                  unknown      connected    configured   unknown
c2::sg/c2t3l7                  unknown      connected    configured   unknown
c2::sg/c2t4l0                  unknown      connected    configured   unknown
c2::sg/c2t4l1                  unknown      connected    configured   unknown
c2::sg/c2t4l2                  unknown      connected    configured   unknown
c2::sg/c2t4l3                  unknown      connected    configured   unknown
c2::sg/c2t4l4                  unknown      connected    configured   unknown
c2::sg/c2t4l5                  unknown      connected    configured   unknown
c2::sg/c2t4l6                  unknown      connected    configured   unknown
c2::sg/c2t4l7                  unknown      connected    configured   unknown
c2::sg/c2t5l0                  unknown      connected    configured   unknown
c2::sg/c2t5l1                  unknown      connected    configured   unknown
c2::sg/c2t5l2                  unknown      connected    configured   unknown
c2::sg/c2t5l3                  unknown      connected    configured   unknown
c2::sg/c2t5l4                  unknown      connected    configured   unknown
c2::sg/c2t5l5                  unknown      connected    configured   unknown
c2::sg/c2t5l6                  unknown      connected    configured   unknown
c2::sg/c2t5l7                  unknown      connected    configured   unknown
c2::sg/c2t6l0                  unknown      connected    configured   unknown
c2::sg/c2t6l1                  unknown      connected    configured   unknown
c2::sg/c2t6l2                  unknown      connected    configured   unknown
c2::sg/c2t6l3                  unknown      connected    configured   unknown
c2::sg/c2t6l4                  unknown      connected    configured   unknown
c2::sg/c2t6l5                  unknown      connected    configured   unknown
c2::sg/c2t6l6                  unknown      connected    configured   unknown
c2::sg/c2t6l7                  unknown      connected    configured   unknown

Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
cleaning up duplicates is just some housekeeping -- not the root cause for your problem of course.

After running "cfgadm -c configure cx" (and "cfgadm -al") you need to run
  devfsadm -c disks
as well.
Now, try
  format < /dev/null
esacadminAuthor Commented:
Well guys, as it turns out it wasnt a problem with the OS at all.  It was the fiber switch port on the brocade switch.  YOu all gave really good answers.  I feel like the points should be divided amongst the people who were the most helpful. Is there a way to do that here?
While closing the question, you can split the points.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.