Local printer is not available on remote desktop connection using Windows XP SP2

Local printer is not available on remote desktop connection using Windows XP SP2
allend1979Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SLafferty1983Commented:
Did you enable the printers to be mapped through the Remote session? Click options on the remote desktop connection and go to the local resources tab. Make sure printers is enabled. Also the remote computer needs to have the driver installed for the printer on your local PC.
0
allend1979Author Commented:
Yes, I did and all port available
0
jeffiepooCommented:
Try sharing the printer, and turn on file and printer sharing.

Hope this helps.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

SLafferty1983Commented:
Is the driver installed on the PC that you are connecting to?
0
allend1979Author Commented:
Driver is installed. There is also a knowlegebase on MIcrosoft but this doesn't help either.
Printers That Use Ports That Do Not Begin With COM, LPT, or USB Are Not Redirected in a Remote Desktop or Terminal Services Session
View products that this article applies to.
Article ID : 302361
Last Review : December 3, 2007
Revision : 4.8
This article was previously published under Q302361
SYMPTOMS
When you use Remote Desktop Connection or the Terminal Services Client version 4.0 or 5.0 to connect to another Windows-based computer from a computer that is not running Windows Server 2003, your local printers may not be redirected. As a result, your local printers are not available in the remote desktop or terminal services session.

For example, if your Windows XP-based computer has a multifunction print device using a DOT4 port, it may not be redirected in a remote desktop session to a Windows 2000- or Windows Server 2003-based computer.
Back to the top

CAUSE
This problem occurs because the printer port does not begin with COM, LPT, or USB. By default, printer port names that do not begin with COM, LPT, or USB are only redirected in Windows Server 2003. By default, multifunction print devices may not be redirected unless you are running Windows Server 2003 on your local computer because they use DOT4 ports.
Back to the top

RESOLUTION
To resolve this problem on a computer that is not running Windows Server 2003, force all ports (including DOT4) on the client computer to be filtered for redirection. To do this, add a DWORD value named FilterQueueType to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor: 1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following key in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR  
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type FilterQueueType, and then press ENTER.
5. On the Edit menu, click Modify.
6. Type FFFFFFFF, and then click OK.
This enables all ports on the client to be redirected.

Can anyone help?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cpenseCommented:
hello allend1979

i assume you're using an XP machine to remote in to another computer.  what kind of computer are you remoting into?  is it another workstation?  a server?  a terminal server?  you may be doing everything correctly but the policies on the machine you're remoting into might be preventing you from mapping printers.  are you remoting into a domain?
0
SLafferty1983Commented:
Did you add the registry keys and then restart your PC?
0
allend1979Author Commented:
Thanks for the help
0
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.