QOS for video Conf

We have 4 sites with Video Conf equipment in them Tandberg units.  I want to setup QOS on the routers at each site to make sure that bandwidth is good for the Video.  We have a 10mbit pipe ate each site.  I have been looking around but most QOS is for Voip.  Can some one point me in the right direction or give the the code I need to to this.  We want to set the QOS for 1.5meg for Video Conf.  The reason we are doing this is because we have seen bad quality when we have multipoint video.  The Tandberg fiolks say this will help.  I can't see how we are having bandwidth issues as we never max out the 10 meg pipe.

Thanks
LVL 1
heincpaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imalc3142Commented:
QOS might help.  Keep in mind that QOS will only help on the network segments the you have control over.  If you ISP has congestion issues, setting up QOS on your network will not help.

Have you done any bandwidth monitoring to see where the issue is?

Also 1.5 Megs is a lot of bandwidth for video.  What bandwidth are you running?  384 Meg gives you a nice call.

VOIP & Video conferencing use the same protocols (H.323) so any equipment that will work for VOIP will work for Video Conferencing.  

0
heincpaAuthor Commented:
We call at 384K and I have been monitoring the the network and I can see the trafic on Netflow.  I am not showing any errors on the network i.e. routers, switches but the tandberg unit showes drop packets though.  Like I said I can't see where we have abandwidth issue, maybe jitter and I thought QOS would help with that right?  
0
imalc3142Commented:
Are you codec's connected via a WAN or are all your site internal?  

Also, check the switch ports that are directly connected to your codec's and make sure auto sensing is off (set your bandwidth & duplex manually).  I have seen auto sensing issues cause these type of problems.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

heincpaAuthor Commented:
The codcecs are internal we nat to a public IP to avoid going over the VPN.  I did set the Switch to 100/Full and the Codec to 100/Full but my snmp monitor only reads the codec as 10/full??
0
heincpaAuthor Commented:
Do I put the QOS on the internal or external interface?
0
heincpaAuthor Commented:
When I make my class-maps do I match the following:

h323, Rtcp, rtp audio?
0
imalc3142Commented:
So there is no wan between any or your codecs?

I would put the class maps on the internal interface.  Make sure you add QOS to all of your switches.  

If you are using standard ports on your codecs match H323.

Personally I don't think this will solve your problem, but it it is worth setting up so that  Tandberg tech support will move to a better solution.  

Is your problem consistent all day?  Have you tried connecting at a lower speed like 128, and see if you still have the issue?
0
heincpaAuthor Commented:
Sorry miss understood.  Here is what we have.

Tandberg (head office) ---> switch 2950 --> Router 2811(internal for Vlans) -->  Router (NAT to public ip) --> Internet  --> to Router (Nat back to private address) --> switch 2950 --> tandberg (remote site).  So we do go over the WAN we Nat each Tandberg to a public to avoid going over Point to point VPN we have between all offices.  So would you not put the QOS on the External interface?  Also we have a 10mbit pipe via XO between sites so 15000 kbps would be about 1.5mbps right?  Do I need to use the set dscp in my policy maps?  Here is what I have so far:

class-map match-all Video
 match protocol h323
 match protocol rtcp
class-map match-all Audio
 match protocol rtp audio

Should I make this one class-map?

Thanks for your help.
0
imalc3142Commented:
Im not going to be as much help on the syntax of the class map as I would like.  It's been almost 4 years since I needed to set up QOS in a Cisco network.  Back then I was using access & priority lists.

Your syntax looks good.  I would use one map.

Since you can only control QOS inside your network, I would apply it to your internal interface only.  Again you will need to also configure your switches for QOS.

Again I dont think this is your problem.  But it is a worthy exercise.  

Did you try a conference at lower speeds?  And does your problem happen all day or intermittently?
0
heincpaAuthor Commented:
We have tried different speeds yes and it happens as soon as we add the third party.  with just two paryies evrything looks good.  Add a thrid and the party that started the call looks good but the other two say it looks like crap.

Is there a way you know of that I can watch the the flow over the wan?  I can only manage on internal network so the QOS will give priority on traffic up till it hits the WAN interface correct?
0
imalc3142Commented:
How are you bridging the third site?
0
heincpaAuthor Commented:
We are calling the tandberg direct.  So let say the device in Denver calles Houston call has good picture and sound all looks good.  Then Denver brings in Dallas.  Now the call quality goes down in Houston and Dallas although Denver still looks good.  This is the same on every device.  Dallas startes the call same thing, and Houston and so on.  The Tandberg says it has dropped packets but I am not seeing any droped packets on the switch, router no where.

If I rna this through the VPN could I get QOS to work over the WAN since the VPN is point to point?
0
imalc3142Commented:
sorry I've been out of touch.  Had an emergency project on this end.  You have an interesting problem.  the more you tell me the less I think it's a QOS issue.  

If I understand you correctly, all your Tandberg units have dual codecs and they act a their own bridge.  And the unit that bridges the calls together is the source of the loss packets.  Did I get that correct?  

If this is the case I would go back to Tandberg tech support and stay on the phone until they find out what is going on and don't let them brush your off with another wild goose chase like QOS.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BHIExchCommented:
Qos seems to work when RTP is in place of the class-map.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.