Date format in parameter

In my report I am filtering results depending on a date, I have the default language of my report set to en-AU, however my parameters fail to recognise a date such as 27/11/2007 and displays an error message, however if I change the date to 11/27/2007 it filters the results correctly.

The actual date which appears in my results is formatted correctly, and as soon as I run the report it switches the entry in the parameter field to the right format as well.

Is there anything I can do to rectify the format in the parameter value?
AWSHelpdeskAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ee_rleeCommented:
0
AWSHelpdeskAuthor Commented:
This is similar to my issue, and I am already using this line to format the date parameter after the report is run in a text box at the top of the report, and it works fine;

= IIF(Format(Parameters!sale_date.Value,"dd/MM/yyyy")<>"","Sales by Agent for " & Format(Parameters!sale_date.Value,"dd/MM/yyyy"),"")

But the issue comes when I type for example 27/11/2007 (dd/MM/yyyy format) into the date parameter field and it errors. but if i type 11/27/2007 it runs the report fine and automatically switches the date to 27/11/2007 in the parameter field?
0
ee_rleeCommented:
i think you would have to set your parameter to string then convert it to date/time.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ee_rleeCommented:
0
PFrogCommented:
The format is controlled by the server settings. If you change your SQL Server instance to be en-AU then the date parameters will all show correctly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB Reporting Tools

From novice to tech pro — start learning today.