• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 748
  • Last Modified:

Needed help to setup Wake on Lan Feature on Rhel ws4.0 installed on Dell OptiPlex 620 Desktop Systems

Hi All!

I have been looking to enable WOL(Wake on Lan) Feature on Rhel WS4.0 Installed on Dell OptiPlex 620 Desktops.
Here are the details:
We have a lab of consisting 30 Desktop's out of which 18 are as per above mentioned configuration. Now we have an requirement to enable WOL feature so that user's can wake up these machines in the morning and if there is not activity on the systems for 2 hours then these systems shall get powered down itself. All users have direct access to the Lab Vlan (192.168.212.X/24) so sending any packet to this vlan shall not be any issue.
I can immediately provide the further required information, kindly help me get it resolved.

Regards,
Parveen Khera
pkhera_2001@rediffmail.com
0
pkhera_2001
Asked:
pkhera_2001
  • 2
1 Solution
 
rokovCommented:
WOL is a hardware feature (see http://en.wikipedia.org/wiki/Wake-on-LAN for details). So to enable it you should change bios settings (of course if WOL is supported by motherboard).

As for the other part of your question (turn off PCs) please clear what do you mean by inactivity (for example "no user logged on" or "no user processes running").
0
 
pkhera_2001Author Commented:
Hi!
Checked with bios on mother and it supports wol.
For turn off I mean no user process running for a span of time period, for example 1hour or 2 hours. I am also looking if we can find any option related with hibernation. Like if now user processes running for 2 hours, machine shall go into hibernate state and when ever required machine can be brought back to normal state (Powe on).
Regards,
Parveen Khera
pkhera_2001@rediffmail.com

0
 
rokovCommented:
You may schedule the following command via cron (for example, once in 10 minutes). It check for presence of processes with owner UID >=500 (typically these are user UIDs). If not found it execute shutdown with 2 hour delay. If a user process is found it cancels previously scheduled shutdown.

I have no experience with hibernation on linux, so can't help you here.

bash -c "for uid in \`ps -eo uid --no-heading\`; do [[ $uid -ge 500 ]] && /sbin/shutdown -c && exit ; done || /sbin/shutdown -h +120"

Open in new window

0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now