REORG FAILING

REORG of a tablespace is failing.
I altered the secqty and priqty of the TS and then stopped and started the database when I got 'not able to allocate next extent message'
now after inreasing the secqty,it gives this message
-DSNT500I    DSNUGBAC - RESOURCE UNAVAILABLE
                       REASON 00C2010D
                       TYPE 00000220
                       NAME UCTEST01.DSNDBC.DZ034912.STMDDGX.I0001.A001
-DSNU017I    DSNUGBAC - UTILITY DATA BASE SERVICES MEMORY EXECUTION ABENDED, REA
REASON=X'00E40009' CAUSE=X'00C9000A'.
please advise
NigelleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NigelleAuthor Commented:
just to add my tablespace has two partitions
0
NigelleAuthor Commented:
my table is now in --904
0
Kent OlsenData Warehouse Architect / DBACommented:
Hi Nigelle,

I believe that your database is in need of serious help.  :(

Based on the messages, it appears that the logical volume ran out of space (or failed), resulting in the first message (not able to allocate next extent).  The table in -904 suggests that the reorg was "in progress" and not at a stable point when DB2 was brought down.

I suspect that you're going to have to rebuild this database.


Good Luck,
Kent
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

momi_sabagCommented:
hi
i need you to tell me exactly what you did
what do you mean by stopping and starting the database ?
did you run
-stop db(DZ034912) ?
or did you shut down db2 ?

please provide the exact commands you performed and the order you performed them

in order to fix the error you get, you can run the repair utility on this tablespace with the levelid argument
but first send me the commands you run, so we can make sure no furthur damage is done
0
NigelleAuthor Commented:
I did repair levelid and now I am able to access the table but when I run through the application program it gives -904.I ran a rebuild index(all) and now the application program run failed with sqlcode -471 and reason 00E79002 and sqlstate 55023.The reorg gives S04Ewith  REASON=X'00E40005' before and after the rebuild.Please help out

0
momi_sabagCommented:
hi

00E79002 means that db2 could not run a procedure or user defined function. use the display procedure or display function command to see if the command is in stop state, if so, use start procedure / function to start it, that is the most commomn error for this reason code, otherwise we will search another solution
00E40005 means there was an error with mvs sort.
can you post here the reorg command and the output you see in sysprint ?
how big is the table ? how many rows, what is the row size and how many indexes are there ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB2

From novice to tech pro — start learning today.