VNC on fedora

Hi all,

I am having trouble understanding the vnc service on my fedora box.  I have xvnc service running but if I restart the service I get:

[root@ftpserver ~]# service vncserver restart
Shutting down VNC server: 1:root 2:steve                   [FAILED]
Starting VNC server: 1:root
New 'ftpserver.khlgroup:1 (root)' desktop is ftpserver.khlgroup:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/ftpserver.khlgroup:1.log

2:steve runuser: warning: cannot change directory to /home/data/it: No
such file or directory
-bash: line 0: cd: /home/data/it: No such file or directory
                                                          [FAILED]

Also I dont understand how it works regarding the reote desktop itself.  Does it open a different session of the desktop, do you have to log in as a user or can you log in as root? or is it a simple remote desktop where you take control of the mouse and keyboard from another location.

Please help and thanks in advance
Steve (keen to learn VNC!)
stevemarsh99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

http:// thevpn.guruCommented:
[root@ftpserver ~]# service vncserver restart
Shutting down VNC server: 1:root 2:steve                   [FAILED]
Starting VNC server: 1:root
New 'ftpserver.khlgroup:1 (root)' desktop is ftpserver.khlgroup:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/ftpserver.khlgroup:1.log

2:steve runuser: warning: cannot change directory to /home/data/it: No
such file or directory
-bash: line 0: cd: /home/data/it: No such file or directory
                                                          [FAILED]


The first fail is because VNC is not running so stopping it will fail..the second error is because /home/data/it does not exist you might wana create it that way the server might start.

As for VNC server it allows a user to connect to your Fedora box with Keyboard and Mouse access.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stevemarsh99Author Commented:
Where is that directory specified?  I couldnt see it in the xvncserver (or similar) file?  And why do I need it?
0
stevemarsh99Author Commented:
I have created the directory as suggested and I get :

[root@ftpserver ~]# service vncserver restart
Shutting down VNC server: 1:root 2:steve                   [FAILED]
Starting VNC server: 1:root
New 'ftpserver.khlgroup:1 (root)' desktop is ftpserver.khlgroup:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/ftpserver.khlgroup:1.log

2:steve                                                    [FAILED]
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

NopiusCommented:
> Does it open a different session of the desktop, do you have to log in as a user or can you log in as root?

While VNC only allows access to your current local session (as shakoush2001 said), you may also want to have multiple resumable sessions for different users. The second can be done with 'freenx' Fedora package, go http://www.nomachine.com/ for some dox.

In Gnome in Fedora you may enable VNC access directly from menu.

I have no Fedora running right now and can't help you with the above errors.
0
malcolm_logan_ukCommented:
The easiest way to enable VNC in Fedora is from the Preferences menu - Remote Desktop.

Works brilliantly.

M
0
stevemarsh99Author Commented:
I have enabled that setting but I get this error when connecting from the client using ftpserver:1 (not that I know what that means!):

Connection timed out: (10060)
0
NopiusCommented:
Change your firewall settings to allow X11 traffic.


iptables -I INPUT -p tcp -m multiport --port 6000:6010 -j ACCEPT

or for permanent changes run 'iptables-save > /etc/sysconfig/iptables', add appropriate line and run 'iptables-restore < /etc/sysconfig/iptables'


> ftpserver:1 (not that I know what that means!):

'ftpserver' means to connect to host name 'ftpserver', you may use IP address instead
':1' means that the display is number one (client will connetc to tcp port 6001 in firewall).
0
NopiusCommented:
I'm sorry, for VNC the port range is 5900:5910, not 6000:6010 (which is for X11 connection).

0
stevemarsh99Author Commented:
I already have that range open (for FTP I think) but if I type ftpserver.(domain):0 I get:

unable to resolve host by name: The requested name is valid, but no data of the requested type was found. (11004)
0
NopiusCommented:
stevemarsh99, use IP address of ftpserver
0
stevemarsh99Author Commented:
I have used both and they both result in the same thing
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.