[Webinar] Streamline your web hosting managementRegister Today

x
?
Solved

Urgent Help needed with Cisco 3750 Config

Posted on 2008-02-12
27
Medium Priority
?
534 Views
Last Modified: 2012-08-13
I'm am desperate for help in configuring a Cisco 3750 PoE. I have typed in the below config but I simply can't ping its own address let alone anything else on the network- (10.244.15.249)

I have tried (start erase) to reboot the config but it doesn't appear to do a complete reset. I'm a bit of a novice in regards to Cisco put any help would be appreciated.

What I am trying to do is get this switch speaking to another 3750 across a 100mb LAN extension link but I'm worried as I can't even give the switch its own ip address therefore I can't do anything with it.

Please help!!

Vtp domain HLI
Vtp mode client
Vtp password Cade332! (or C0nverg3nc3)

int vlan 99
  ip address 10.244.15.249 255.255.252.0
exit

int g0/23
Description *****LES 100 to SJC*****
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 99,100,110,200
 switchport mode trunk

ip route 0.0.0.0 0.0.0.0 10.244.15.254 (this is the gateway address)

copy run start
0
Comment
Question by:adterry79
  • 10
  • 8
  • 7
  • +1
27 Comments
 
LVL 21

Expert Comment

by:from_exp
ID: 20874106
hi!
i don't think you need vtp in your simple config.
you have configured your switch with ip address on vlan99
are you sure your pc is plugged into port configured with vlan 99?
if int gi1/0/23 is plugged to another switch, does the second one configured with trunk mode to accept vlans 99,100,110,200?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 20874259
Did you actually create vlan 99 on the switch?

conf t
vlan 99
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20874321
conf t
vlan 99
name <vlan name>
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 

Author Comment

by:adterry79
ID: 20874394
All i'm after doing is joining this switch to an exisitng switch over the network so I'm presuming I don't need to create the vlan 99, should this not just come across from the other switch?

I have allowed access to the vlans from the other switch hence why I have changed the vtp mode to client as I want the 2 to communicate with one another.

Do you think I need to create the vlan rather than rely on the other switch?
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20874419
yep, i suppose, you have to maintain vlans on each switch.
at least now, for debug purposes.
can you console to the switch?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 20874424
VTP will work as long as the trunk is up.  Also enable " ip routing"

conf t
ip routing

Does a "show vlan" show VLAN 99 and the other VLAN's on the switch?

Does a "show int g0/23" show the port as up/up?

Does a "show int trunk" show the trunk established?

Does a "show ip int brief" show the VLAN99 interface up/up.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20874454
>I have typed in the below config but I simply can't ping its own address...

Did you "no shut" the interface? All layer 3 interfaces are admin down by default.
0
 

Author Comment

by:adterry79
ID: 20874766
PLease see the attached confgis when I have done
sh int g1/0/23
sh int vlan 99
sh run
sh vtp status

As you can see vlan 99 is down and despite doing no shutdown, I can't get it back up. All the lights are green indicating there is connectivity over the LES.
shintg1023.txt
shinvlan99.txt
shrun.txt
shvtp.txt
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20874810
as you can see from vpt output your switch does not see vtp server
i would recommend create vlan on the switch:
conf t
vlan 99
name <name of vlan>
end
you can also configure port gi1/0/2 with vlan 99 for testing:
conf t
int gi1/0/2
sw mo ac
sw ac vl 99
end

after that vlan interface will be up
and plugging your pc to port 2 you will be able to ping your switch
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20874848
Your VLAN 99 interface is down because the switch has no VLAN 99.

The switch is not learning the VLAN through VTP because you don't have a functioning trunk. The G1/0/23 may be showing up, but there's no traffic on the interface. I suspect it's a speed or duplex problem. 100m / half duplex on that port is curious. What's the other end set to?

0
 

Author Comment

by:adterry79
ID: 20874859
I can do that but our primary network is across in a different building and just being able to ping the router is great however, I need to be able for the 2 switches to see each other otherwise we can't provide full network access in the new building.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20874891
when you create the vlan, you will be able to ping the switch, then you should take a look at the other side of gi1/0/23 port to see if the configuration there is correct.
0
 

Author Comment

by:adterry79
ID: 20876238
I can now connect to the switch fine now using the manual vlan. On the other switch, I have allowed port 23 to allow all vlans and I still can't ping the other switch! Can you see any errors here as I'm losing the will to live!
GBMAN3750CORE#sh int g1/0/23 trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/23    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/23            1-4094

Port                Vlans allowed and active in management domain
Gi1/0/23            1-6,99-100,110,120,200,210

Port                Vlans in spanning tree forwarding state and not pruned
Gi1/0/23            1-6,99-100,110,120,200,210
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20876374
Can you post a "show inter trunk" from the other switch?
0
 

Author Comment

by:adterry79
ID: 20876447
Here you go
GBMAN3750CORE#sh inter trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/0/1     on               802.1q         trunking      1
Gi1/0/23    on               802.1q         trunking      1
Gi1/0/24    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/0/1             3,6
Gi1/0/23            1-4094
Gi1/0/24            1-4094

Port                Vlans allowed and active in management domain
Gi1/0/1             3,6
Gi1/0/23            1-6,99-100,110,120,200,210
Gi1/0/24            1-6,99-100,110,120,200,210

Port                Vlans in spanning tree forwarding state and not pruned
Gi1/0/1             3,6
Gi1/0/23            1-6,99-100,110,120,200,210
Gi1/0/24            1-6,99-100,110,120,200,210
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20876522
If g1/0/1 is at the other end, that's your problem. VLAN 99 isn't allowed on the trunk.



int g1/0/1
 switchport trunk allowed vlan add 99

Open in new window

0
 

Author Comment

by:adterry79
ID: 20876554
So I just need to add this on the other switch and then this should work?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20877713
If the first switches g1/0/23 is connected to this switches g1/0/1, then yes.
0
 

Author Comment

by:adterry79
ID: 20878767
Both terminating ends of the LAN extension both terminate in port 23 in both switches.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 20879145
Then that's not the problem. What is the IP address you're trying to ping on GBMAN3750CORE?

Can you post the output from a "show run" or at least a "show ip int brief"?
0
 

Author Comment

by:adterry79
ID: 20882670
GBMAN3750CORE#sh ip int brief
Interface              IP-Address      OK? Method Status                Proto
Vlan1                  unassigned      YES NVRAM  administratively down down
Vlan6                  10.244.19.254   YES manual up                    up
Vlan99                 10.244.15.254   YES manual up                    up
Vlan100                unassigned      YES manual up                    up
Vlan110                10.244.23.254   YES NVRAM  up                    up
Vlan120                10.244.27.254   YES NVRAM  up                    up
Vlan200                10.244.31.254   YES NVRAM  up                    up
Vlan210                10.244.35.254   YES NVRAM  up                    up
GigabitEthernet1/0/1   unassigned      YES unset  up                    up
GigabitEthernet1/0/2   unassigned      YES unset  up                    up
GigabitEthernet1/0/3   unassigned      YES unset  up                    up
GigabitEthernet1/0/4   unassigned      YES unset  up                    up
GigabitEthernet1/0/5   unassigned      YES unset  up                    up
GigabitEthernet1/0/6   unassigned      YES unset  up                    up
GigabitEthernet1/0/7   unassigned      YES unset  up                    up
GigabitEthernet1/0/8   unassigned      YES unset  down                  down
GigabitEthernet1/0/9   unassigned      YES unset  down                  down
GigabitEthernet1/0/10  unassigned      YES unset  down                  down
GigabitEthernet1/0/11  unassigned      YES unset  down                  down
GigabitEthernet1/0/12  unassigned      YES unset  down                  down
GigabitEthernet1/0/13  unassigned      YES unset  down                  down
GigabitEthernet1/0/14  unassigned      YES unset  down                  down
GigabitEthernet1/0/15  unassigned      YES unset  down                  down
GigabitEthernet1/0/16  unassigned      YES unset  down                  down
GigabitEthernet1/0/17  unassigned      YES unset  down                  down
GigabitEthernet1/0/18  unassigned      YES unset  down                  down
GigabitEthernet1/0/19  unassigned      YES unset  down                  down
GigabitEthernet1/0/20  unassigned      YES unset  down                  down
GigabitEthernet1/0/21  unassigned      YES unset  down                  down
GigabitEthernet1/0/22  unassigned      YES unset  down                  down
GigabitEthernet1/0/23  unassigned      YES unset  up                    up
GigabitEthernet1/0/24  unassigned      YES unset  up                    up
GigabitEthernet1/0/25  unassigned      YES unset  down                  down
GigabitEthernet1/0/26  unassigned      YES unset  down                  down
GigabitEthernet1/0/27  unassigned      YES unset  down                  down
GigabitEthernet1/0/28  unassigned      YES unset  down                  down

mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
class-map match-all AutoQoS-VoIP-RTP-Trust
  match ip dscp ef
class-map match-all AutoQoS-VoIP-Control-Trust
  match ip dscp cs3  af31
!
!
policy-map AutoQoS-Police-CiscoPhone
  class AutoQoS-VoIP-RTP-Trust
   set dscp ef
    police 320000 8000 exceed-action policed-dscp-transmit
  class AutoQoS-VoIP-Control-Trust
   set dscp cs3
    police 32000 8000 exceed-action policed-dscp-transmit
!
!
!
interface GigabitEthernet1/0/1
 description ***St James 802.1q trunk link to existing LAN Vlans 2,3,4,5,6***
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 3,6
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust dscp
!
interface GigabitEthernet1/0/2
 description ***GBMANCCM01***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 description ***GBMANCCM02***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 description ***GBMANIPFX01***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 description ***GBMANIPFX02***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 description ***GBMANVG01***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 description ***GBMANVG02***
 switchport access vlan 210
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust dscp
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 switchport access vlan 6
!
interface GigabitEthernet1/0/9
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/10
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/11
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/12
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/13
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/14
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/15
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/16
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/17
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/18
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/19
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/20
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/21
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/22
 description DATA ONLY
 switchport access vlan 6
!
interface GigabitEthernet1/0/23
 description ****LES 100 to King Street****
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet1/0/24
 description ***LES 100 to Tootal House***
 switchport trunk encapsulation dot1q
 switchport mode trunk
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 srr-queue bandwidth shape  10  0  0  0
 queue-set 2
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet1/0/26
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet1/0/27
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet1/0/28
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan6
 description ***New DATA_Vlan***
 ip address 10.1.14.2 255.255.255.0 secondary
 ip address 10.244.19.254 255.255.252.0
!
interface Vlan99
 description ***Management_Vlan***
 ip address 10.244.15.254 255.255.252.0
!
interface Vlan100
 no ip address
!
interface Vlan110
 description ***SERVER_Vlan***
 ip address 10.244.23.254 255.255.252.0
!
interface Vlan120
 description ***PRINTER_Vlan***
 ip address 10.244.27.254 255.255.252.0
!
interface Vlan200
 description ***Phone_Vlan***
 ip address 10.244.31.254 255.255.252.0
 ip helper-address 10.244.32.11
!
interface Vlan210
 description ***PhoneSERVER_Vlan***
 ip address 10.244.35.254 255.255.252.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.244.20.20
ip route 10.0.0.0 255.0.0.0 10.1.14.1
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
 password 7 112A490B0117190B57242877
 login
line vty 0 4
 password 7 112A490B0117190B57242877
 login
 length 0
line vty 5 15
 password 7 112A490B0117190B57242877
 login
 length 0
!

0
 
LVL 21

Expert Comment

by:from_exp
ID: 20882747
hi there!
take a look at your gi1/0/23 port:
interface GigabitEthernet1/0/23
 description ****LES 100 to King Street****
 switchport trunk encapsulation dot1q
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 spanning-tree portfast
 service-policy input AutoQoS-Police-CiscoPhone

it lacks one string:
switchport trunk allowed vlan 99,100,110,200

so the port was configured as trunked, but without allowed vlans.
0
 

Author Comment

by:adterry79
ID: 20882950
I have now made this change but it still won't ping.

Is it worth trying the 2 switches in the same building linked together via a cat 5 cross over cable??
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20883129
hm, no big difference.
please provide for both switches:
sh int gi1/0/23
sh run int gi1/0/23
sh mac-ad int gi1/0/23
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 20883334
It is not necessary to allow vlans on a trunk. By default, all VLAN are allowed.

It would appear that this port was at one time connected to a phone. And you've got some non inter-switch commands on the config for this interface.  I would suggest removing any non-default commands and get the link working as a trunk.




interface GigabitEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk

Open in new window

0
 

Author Closing Comment

by:adterry79
ID: 31430113
It was due to a fibre connection fault as to why it wasn't working. Its now fully operational, thanks for all your help.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 20883680
before reconfiguring port as was recommended by donjohnston, please provide the output of the commands I have requested.
in case donjohnston proposal is correct it will be easier for us to understand why do qos settings block normal data
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
This video tutorial shows you the steps to go through to set up what I believe to be the best email app on the android platform to read Exchange mail.  Get the app on your phone: The first step is to make sure you have the Samsung Email app on your …

591 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question