• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 533
  • Last Modified:

Error message reeived when opening file.

Hi there,

We designed a website which is connected to an access database and running on Server 2003 64bit edition under IIS6 using the OLEDB command 12. When we try to acces the site we get the following message:

System.InvalidOperationException: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

Any idea why this is happening and how we can solve the problem.

Thanks

Bernard
0
burny1
Asked:
burny1
  • 2
1 Solution
 
RubalJCommented:
You'll need to install office 2007 interops on the web server which can be downloaded from

http://www.microsoft.com/downloads/details.aspx?familyid=59DAEBAA-BED4-4282-A28C-B864D8BFA513&displaylang=en
0
 
Ashok KumarCommented:
Incase if you are using access 2007 as your datastore, then need to install "Office System Driver: Data Connectivity Components" in server.
http://www.microsoft.com/downloads/details.aspx?FamilyID=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en
0
 
burny1Author Commented:
Hi
We installed everything but to no avail.  A bit more info.  The site has been built on a XP Pro SP2 machine 32bit version and the site works when you run it from that machine. When we try to host on a win2003 x64 server we get this problem. When you try and run the site from the XP machine and host the datat file on the network it gives errors in that it does not want to use a network drive - something which is also very weird. We tried to convert the site using Visual Studio 2008 Configuration Manager to X86, however that option is not available even though everyone talks about it.

Any other ideas or info on where we can find this module.

Thanks

Burny1
0
 
burny1Author Commented:
Hi
We installed everything but to no avail.  A bit more info.  The site has been built on a XP Pro SP2 machine 32bit version and the site works when you run it from that machine. When we try to host on a win2003 x64 server we get this problem. When you try and run the site from the XP machine and host the datat file on the network it gives errors in that it does not want to use a network drive - something which is also very weird. We tried to convert the site using Visual Studio 2008 Configuration Manager to X86, however that option is not available even though everyone talks about it.

Any other ideas or info on where we can find this module.

Thanks

Burny1
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now