[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1176
  • Last Modified:

cannot connect to internet when connected to my pptp vpn connection

Hello

I'm looking for help w/ connecting to the internet while on my pptp connection to my PIX.

I don't have a server on my network.

when my pptp tunnel is up I can hit the remote network but unable to open the internet the page times out.

Someone said I need to create a static route back thru the pix in order to hit the internet.

any help would be greatly apprishiated
-------------------------------------------------------------------------------
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix501
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any interface outside eq ssh
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.10.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool mypool 192.168.10.130-192.168.10.140
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 192.168.1.13 /home_pix_501.cfg
floodguard enable
sysopt connection permit-pptp
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 20
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 20
console timeout 0
vpdn group pptp accept dialin pptp
vpdn group pptp ppp authentication pap
vpdn group pptp ppp authentication chap
vpdn group pptp client configuration address local mypool
vpdn group pptp client configuration dns 68.87.64.146 68.87.75.194
vpdn group pptp pptp echo 60
vpdn group pptp client authentication local
vpdn username remoteconnect password *********
vpdn enable outside
dhcpd address 192.168.1.3-192.168.1.129 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
0
rclose1977
Asked:
rclose1977
  • 2
1 Solution
 
lrmooreCommented:
When using PPTP, your VPN client pool needs to be a sub-set of your internal address pool. That way, you can un-check "use default gateway on remote network" in your client dialer network properties.
You can un-check that anyway and get Internet access while connected, but you will lose connectivity to the network inside the PIX. You could use a temporary measure by using "route print" on your PC to determine your VPN connection IP address, the manually delete the default, add a new static and a new default:
If my VPN client IP address = 192.168.10.130

C:\>route delete 0.0.0.0 mask 0.0.0.0 192.168.10.130
C:\>route add 192.168.1.0 mask 255.255.255.0 192.168.10.130

Not very easy when your client IP address is subject to change every time you connect.

0
 
_m3Rlin_Commented:
0
 
16spam16Commented:
Here is my Local LAN settings..
IP: 192.168.1.101
Subnet: 255.255.248.0
Def Gateway: 192.168.1.1

DNS1: 68.87.72.134
DNS2: 68.87.77.134

~~~~~~~~~~~~~~~~~~~~
This is what my office settings would be:

IP: 192.168.254.54
Subnet: 255.255.255.0
Def Gateway: 192.168.254.254

DNS1: 192.168.254.2
DNS2: 216.231.41.2
0
 
16spam16Commented:
On my VPN connection, i use DHCP server to Auto assign an IP.
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now