How do I maximize application to two displays using TwinView

Hi!

I have a computer with two displays (using both the DVI and VGA ports on
a Nvidia graphics card). Now I would like to have the two displays to act as
one big virtual display where I can, for example, maximize firefox so
that it is shown on both displays. I running this on top of an Ubuntu 7.10 installation.

I have used the nvidia-settings application and when invoked for the first time (after a clean dpkg-reconfigure xserver-xorg) and configured to use TwinView the desired effect appears. However after I saved (both tried with merging the original xorg.conf and as a new one) and restarted the X-server the tasklist and program bar only shows on the primary display and windows only gets maximized to one display at a time.

Help in this matter is much appreciated! :)

I attach my xorg.conf.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007
 
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
 
Section "ServerLayout"
 
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection
 
Section "Files"
EndSection
 
Section "Module"
EndSection
 
Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection
 
Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "se"
EndSection
 
Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection
 
Section "Monitor"
    Identifier     "Allmän skärm"
    HorizSync       30.0 - 65.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection
 
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PMT"
    HorizSync       31.0 - 92.0
    VertRefresh     50.0 - 85.0
EndSection
 
Section "Device"
    Identifier     "nVidia Corporation NV34 [GeForce FX 5200]"
    Driver         "nvidia"
    Option         "UseFBDev" "true"
    BusID          "PCI:0:20:0"
EndSection
 
Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
EndSection
 
Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV34 [GeForce FX 5200]"
    Monitor        "Allmän skärm"
    DefaultDepth    24
    SubSection     "Display"
        Modes      "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
 
Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: nvidia-auto-select +1280+0; DFP-0: 1280x960 +0+0, DFP-1: nvidia-auto-select +1280+0; DFP-0: 1024x768 +0+0, DFP-1: nvidia-auto-select +1024+0; DFP-0: 800x600 +0+0, DFP-1: nvidia-auto-select +800+0; DFP-0: 640x480 +0+0, DFP-1: nvidia-auto-select +640+0"
EndSection

Open in new window

drexlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
Hi

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Change "Xinerama" "0" to "Xinerama "1" and restart your x server (ctrl+alt+backspace)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
drexl, Did my advice work out for you?

PeturIngiEgilsson
0
drexlAuthor Commented:
Hi PeturIngiEgilsson

I havn't yet had the time to try your suggestion out since the system I was configuring is at another place. So I'm about to test it soon. However, I was under the impression that twin view wasn't compatible with xinerama (since it is supposed to be pretty much the same thing only twin view is specifically for nvidia cards).

Another thing with xinerama is that open gl functionallity only can be used in one display (from what I've read) and I think I need to be able to use such things in both displays. Do you know if this is the case or not?

I'll report back when I've tried the xinerama-fix you've suggested - thanks!
0
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
You are right, i'm so very sorry.
You need to run nvidia-settings as root ( sudo nvidia-settings )
Last time i used nvidia-settings ( like 3 months ago.. ) i was bugged (it says the configuration have been applied and saved.. but it had really not been.. as you need root privil. to write to the /etc/X11/xorg.conf file )

Remember to make backup of your xorg.conf file before you modify it..
0
drexlAuthor Commented:
Would you look at that! It worked. I haven't tried gl functionality on both displays though. According to what I've read elsewhere you shouldn't use twin view with xinerama since they are supposed to be mutual exclusive - but it worked for me :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.