No volume with external drive in logical disk management

situation:

SBS 2003 sp1
hp ML110 G4
when I connect a USB external hard disk drive (WD my book 320) the external disk drive is visible as a disk 1 but does not show volumes in the logical disk management. It shows the correct size but it does not get a drive letter. when u try to get the properties of the volume it gives a error: "The operation was canceled due to an internal error". If u try to change the drive letter it gives the following message. "the operation did not complete. Check the event log for more information on the error. close the disk management console, then restart disk management before retrying the operation." and u will get this error every time u try this. when u try to delete the partition after a long time it will give a timeout.
In the device manager all devices are installed ok. no errors in the logbooks.

Things I tried:
when the disk is connected to a other computer it works right away and the partition is visible.
updating and downgrading drivers from usb and disk. the tape drive is connected to the same usb hub and is working properly. also tried other usb ports.
when I connect any memory stick on the same usb port it works.
when I connect a MY BOOK 500GB it gives the same error. (also a WD HDD)
when I connect a "120 gig WD HDD IDE" through a ide to usb converter it gives the same error.
deleted all traces of de western digital disk in from the memory.

how did I manage to get this strange problem.
we restored the old server (HP ML110 G3) to the new server (HP ML110 G4) with Symantec system recovery 7.
while restoring I used the option restore anyware to ensure maximal compatibility with the new server. (tried without restore anyware option but it gave some problems)
all works well. all the hardware is functionally good. also the databases, exchange server, backups all working without any problems. its just that this external backup disk used for backup to disk is not recognized. which is strange because i restored the server from the same USB hard drive.

I hope someone has any ideas or has had the same problem? because I got stuck with no more good options left.
tmsoetemanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MarkMichaelCommented:
Have you checked the properties of the USB drive once its attached in device manager?
0
tmsoetemanAuthor Commented:
I checked the properties, and all is installed good.
"device working properly"
see image attached.
ServerHDDprobleem.jpg
0
briancassinCommented:
Try this

Go to start run type regedit press enter
go to this key HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
right click on the key and check the permissions
administrator and system should have full control if not this may be the problem set the permissions by clicking on advanced then inherit permissions also check the replace permissions on child objects option

Its possible to simply delete the devices registry keys instead of renaming them in the instructions below. But make sure that you do a backup for the registry branch by exporting MountedDevices key, as mistake may cause your system unbootable. The delete all possible USB drives, FireWire drives and external drives which have drive letter temporarily only when inserted in the system, and DO NOT delete any of the fixed hard disk drives or CD/DVD optical drives registry values.

In the right pane, find and locate a registry value which represents the troubled USB or FireWire drive. The registry key should have the name that resembles the format of \DosDevice\X: where X can be any alphabet letter which corresponding to your physical system drive letter.

You may also see entries that say \??\Volume{fd2b8768-ac1e-11d9-9d4c-806d6172696f} for example

Heres a guidelines that you can follow to quickly determine which registry key is linked to your conflicted drive letter:

Exclude \DosDevice\A: and \DosDevice\B: which normally reserved for floppy disk drives.
Exclude \DosDevice\C: which normally is the system root drive.

If you have more than one fixed hard disk drives, then any drive letters that are using by them is not possible linked again, UNLESS the additional hard disk drive is added AFTER you first use the USB or FireWire device that now unable to show.
Same case with CD-ROM or DVD-ROM optical drive as above reasoning.
If you have inserted and mounted a lot of thumbdrives, USB flask drive, or external hard disks before, you will likely still see a lot of remaining registry values that you wont know which is which. In this case, double click on each remaining registry key values to view its binary data. Inside the binary data, there will be trace of the name of the device that this registry key represents. For example, figure below shows a Sandisk Cruzer micro USB flash drive.

With this information, search for a registry value that contains name of your USB or FireWire drive brand and model that having problem showing up in Explorer.

Once the correct registry value is determined (for example, \DosDevices\F:), right click on the registry value name, and the select Rename.

Change the drive letter (in the example is F) to another unused drive letter that hasnt been used by another other drives, then press Enter.
Now insert and plug in the USB or FireWire device into the port again (if its already inserted, take it out and re-insert again). The drive letter for the USB and FireWire should now appear and you can use the drive normally and properly again.

Let me know if this works
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

tmsoetemanAuthor Commented:
I had a look at this, but there is not mutch to delete. i took away the F device but it looks like nothing changed.
i even rebooted the server. still same problem.
see image file for visual view of registry and disk management.

i hoop u have more ideas. it looked good. i already looked here but found nothing wrong checked the rights and everything.
please anyone!! :)
ServerHDDprobleem1.jpg
0
briancassinCommented:
did you check under the  \??\Volume  entries ?

Check also under these keys (make a backup of the reg areas before you modify anything i case anything goes wrong)

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

see if there is a listing for the drive under either of these and/or any other external drives follow the same guidlines as above however any that you do find that are not the permanent system drives etc.. (as stated above ) then DELETE them. Reboot and try again.

IF that still doesn't work try creating a new user profile on the computer and then try logging in under that and connecting the drive if it works we are dealing with a profile issue if it does not work then we are dealing with a system wide hardware / software issue.

Did this drive ever work on this computer ?

You mentioned you have a tape drive have you tried turning that off, disconnecting it and disabling it's software/drivers ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gary StevensConsultantCommented:
I notice you have a C: disk and B: disk
Which drive has been selected for the CD drive?

What shared drives are attached at logon?

This problem is usually caused when a mapped drive uses the next available drive letter, for example E: or F: and that is also the next hardware letter available.
What is the drive letter used for the Large 273GB drive?
0
tmsoetemanAuthor Commented:
i am glad to inform u that this problem is solved now.
when i connected with a other user there was no problem with changing the drive letters.

thank u all for thinking with me!
special thanks to braincassin. i reward the points to u.
0
tmsoetemanAuthor Commented:
thq :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.