?
Solved

Offline Address Book Synchronization Error

Posted on 2008-02-12
10
Medium Priority
?
994 Views
Last Modified: 2009-05-18
I have put in a 2007 Exchange server. We migrated the public folders and all mail boxes to the new server. Mail comes in and out fine everything is working good except for this error.

This error only comes up on some machines not all of them. The only thing common I can find it that it seems to be coming up on machines that are logging into and having policies issued from the exchange server.

I have 2 servers both are AD, DC's and Global Catalog severs. One rund exchanges the other is file, print, DHCP, ETC.

When I run gpresutl on the machines that are getting the errors. The login server is the exchange server. The machines that do not get the error is the other server.

So it kind of seems ad is not replicating correctly. But when I add a new user on either server this change is updated accuratly and quikly.
0
Comment
Question by:rfranta
  • 6
  • 3
9 Comments
 
LVL 8

Expert Comment

by:Ubuntop
ID: 20877885
Have you removed the old exchange servers?

The OAB on 2003 is stored in the public folders as a system folder.  So if they are removed then the OAB is gone.  You can create a new one in 2007 easily.  In fact it is better to create a new one in 2007 because it has more features; like being stored in IIS and in the PF.  Simply create a new OAB, then assign it to each of the mailbox stores.

After this is replicated, a user just needs to get out and back into outlook.  You can test it by Tools >> Send/Receive >> Download address book.
0
 

Author Comment

by:rfranta
ID: 20877926
The old server is gone.

I did create a new offline address book in 2007. I thought when I did that it was assigned to the mailbox store. How do I make sure it is or how do I assign it.

Thanks
0
 

Author Comment

by:rfranta
ID: 20877942
OK I found it.. Yes it is assigned to the mailbox store. I will try and delete it and recreate it.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 

Author Comment

by:rfranta
ID: 20878001
I created a new offline address book. Attached it to teh mailbox storgage group and still have the same problem. Is there somewher eto get more detailed information for this error.
0
 
LVL 8

Expert Comment

by:Ubuntop
ID: 20878196
Did you right click the OAB and choose update after you changed the DB defaults?
Organization Config >> Mailbox >> Offline Address Book >> Right Click >> Update

This should publish to your GALs, but if you are suspecting a replication error; try replicating in sites and services.

Also, the cached mode outlook user will need to log out of Outlook after replication has taken place.
0
 

Author Comment

by:rfranta
ID: 20929518
That did the job on the OAB But I am still seeing some problems I can not figure out.

In an outlook client, if I go to Tools Address Book, Then Tools Options it will display global address book. When I click on properties it shows Exchange Address Book Provider.

Some PC's show my exchange server's FQDN
Other's show C:\Documents and Settings\user\Local Settings\Application Data\Microsoft\Outlook\

Naturally the ones showing C:\Documents and Settings\user\Local Settings\Application Data\Microsoft\Outlook\ are incorrect and do not show recent changes to GAL.

I can't find a way to update this to point to the exchange server. If I remove the mail profile and re setup outlook on some pc's it will correct i, on others it won't Seems it could be AD releated but my replication is fine.  







0
 
LVL 8

Accepted Solution

by:
Ubuntop earned 2000 total points
ID: 20929649
The ones showing the local path are probably the Cached mode users.  This is normal, cached mode downloads the GAL from exchange and stores it locally.  You can force an update via send/receive >> Download Address Book.
0
 

Author Comment

by:rfranta
ID: 20929944
I did try that and it will download the address book, but it still shows the local setting .

If they are running in cached mode is there a way I can force them to connect and stay connected?
Or what would cause them to run in cached mode?

Thanks for your help here.

Rob
0
 

Author Comment

by:rfranta
ID: 20929976
Ok I found it under setting.... That worked....

Let me see if that solves my problem...

Thanks Again
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this post, we will learn to set up the Group Naming policy and will see how it is going to impact the Display Name and the Email addresses of the Group.
Upgrading from older Exchange server to the latest Exchange server can be tiresome, error-prone and risky, without being a seasoned exchange server administrators. It can become even problematic if you're an organization that runs on tight timeline…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Planning to migrate your EDB file(s) to a new or an existing Outlook PST file? This video will guide you how to convert EDB file(s) to PST. Besides this, it also describes, how one can easily search any item(s) from multiple folders or mailboxes…

600 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question