Exchange 2007 AutoDiscovery & Out of Office Assistnat doesnt work

I just transitioned from Exchange 2003 to 2007.  Everything seemed to be working fine, but recently Outlook 2007 has given errors when trying to use the Out of Office Assistant.  When trying to open this feature, the following message is recieved, "Your out of office settings cannot be displayed,because the server is unavailabe, try again later."

Outlook 2007 clients are connecting using RPC.  What seems strange is that not all of the clients experience this problem.  About 80% of the Outlook 2007 clients cannot open the Out of Office Assistant and 20% have no problems.  When connecting remotely using a VPN, about 50% of the Outlook 2007 clients have the error and %50 work fine.

Please let me know if anyone has suggestions.  Any help is greatly appreciated.
Thanks,
Chris
WSGAdministratorAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
badgermikeConnect With a Mentor Commented:
I have no thoughts on why that would be - ex07 is still a mystery to me

Maybe an IIS restart?

wait ....I just ran my test outlook cmdlt and cam up with a 1013 and 1006 error as well!

....except our exchange organization never had the same problem that yours did!

 We have been running ex07 for months now - my autodiscover error was the solution that I initially posted - whenever I run the cmdlt I get the 1013 and 1006 but everything still seems to work.

I guess since it is working am not going to dig into it until I see a user issue.

Probably something that will be resolved with an update or service pack.



0
 
badgermikeCommented:
I bet when you use owa you can set the Out of office reply -

I am pretty sure that your problem is a setting in IIS

Open Up IIS on your exchange server -
Expand you web sites then your default web site
go to EWS - righ click it go to properties
Go to directory security
Go to authentication and access control - click edit
Disallow anonymous access

Then see if it works.
0
 
WSGAdministratorAuthor Commented:
OWA does allow me to set the Out of Office reply without any problems.  I checked the IIS directory security settings on the EWS virtual directory and Anonymous Access was not enabled.

I have two CAS servers setup in a NLB and a cert from Verisign for owa.mydomain.com, could there be any problems with having an NLB with a cert?
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
WSGAdministratorAuthor Commented:
I took a look at ATIG's blog but I am still having the problem.
http://exchange-genie.blogspot.com/2007/07/autodiscover-ad-attribute.html

I also looked at the following MS KB articles for cert settings, but still no luck.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;896861
http://support.microsoft.com/kb/940726/
0
 
WSGAdministratorAuthor Commented:
Here are the results from a test-outlookwebservices cmdlet.

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address Administrator@mydomain.com.

Id      : 1007
Type    : Information
Message : Testing server pfgcas01.ad.mydomain.com with the published name https://owa.mydomain.com/EWS/Exchange.asmx & https://owa.mydomain.com/EWS/Exchange.asmx.

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://owa.mydomain.com/autodiscover/autodiscover.xml.

Id      : 1013
Type    : Error
Message : When contacting https://owa.mydomain.com/autodiscover/autodiscover.xml received the error The remote server returned an error: (401) Unauthorized.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.
0
 
WSGAdministratorAuthor Commented:
When i try to browse to https://owa.mydomain.com/autodiscover/autodiscover.xml, i get the following response:

<?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
   - <Response>
      - <Error Time="09:17:20.6670006" Id="2880480104">
        <ErrorCode>600</ErrorCode>
        <Message>Invalid Request</Message>
        <DebugData />
     </Error>
  </Response>
  </Autodiscover>
0
 
badgermikeCommented:
What do you get when you press ctrl and click the outlook icon in the notification bar and test the autodiscover settings?
0
 
WSGAdministratorAuthor Commented:
The log returns the following after I recieve a cert error indicating that the cert has an invalid name.  I think thats because it is finding it on the address autodiscover.mydomain.com rather than owa.mydomain.com.

Attempting URL https://owa.mydomain.com/autodiscover/autodiscover.xml found through SCP
Autodiscover to https://owa.mydomain.com/autodiscover/autodiscover.xml starting
Autodiscover to https://owa.mydomain.com/autodiscover/autodiscover.xml  FAILED (0x80072F78)
Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml starting
Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml FAILED (0x800C8203)
Autodiscover to https://autodiscover.mydomain.com/autpdiscover/autodiscover.xml starting
Autodiscover to https://autodiscover.mydomain.com/autpdiscover/autodiscover.xml FAILED (0x80072F78)
Local autodiscover for mydomain.com starting
Local autpdiscover for mydomain.com FAILED (0x800410F)
Redirect check to http://autodiscover.mydomain.com/autodiscover/autodiscover.xml starting
Redirect check to http://autodiscover.mydomain.com/autodiscover/autodiscover.xml FAILED (0x80004005)


0
 
WSGAdministratorAuthor Commented:
For one of the few users that do not experience this problem, their results look like this:

Autoconfiguration has started, this may take up to a minute
Autoconfiguration found the following settings:

Display Name: User, Test

Protocol: Exchange RPC
Server: PFGEXCHCL.ad.mydomain.com
Login Name: test.user
Availability Service URL: https://owa.mydomain.com/EWS/Exchange.asmx
OOF URL: https://owa.mydomain.com/EWS/Exchange.asmx
OAB URL: Public Folder
Unified Message Service URL: https://owa.mydomain.com/UnifiedMessaging
Auth Package: Unspecified

Protocol: Exchange HTTP
Server: owa.mydomain.com
Login Name: test.user
SSL: Yes
Mutual Authentication: Yes
Availability Service URL: https://owa.mydomain.com/EWS/Exchange.asmx
OOF URL: https://owa.mydomain.com/EWS/Exchange.asmx
OAB URL: Public Folder
Unified Messaging Service URL: https://owa.mydomain.com/UnifiedMessaging
Auth Package: NTLM
Certificate Principal Name: msstd:owa.mydomain.com
0
 
badgermikeCommented:
0
 
badgermikeCommented:
can you test the autodiscover settings for users who have the problem or does it not even work?
0
 
WSGAdministratorAuthor Commented:
These are the results for one of the users that do not have this working.

Attempting URL https://owa.mydomain.com/autodiscover/autodiscover.xml found through SCP
Autodiscover to https://owa.mydomain.com/autodiscover/autodiscover.xml starting
Autodiscover to https://owa.mydomain.com/autodiscover/autodiscover.xml  FAILED (0x80072F78)
Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml starting
Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml FAILED (0x800C8203)
Autodiscover to https://autodiscover.mydomain.com/autpdiscover/autodiscover.xml starting
Autodiscover to https://autodiscover.mydomain.com/autpdiscover/autodiscover.xml FAILED (0x80072F78)
Local autodiscover for mydomain.com starting
Local autpdiscover for mydomain.com FAILED (0x800410F)
Redirect check to http://autodiscover.mydomain.com/autodiscover/autodiscover.xml starting
Redirect check to http://autodiscover.mydomain.com/autodiscover/autodiscover.xml FAILED (0x80004005)
0
 
badgermikeCommented:
Very weird. I haven't delt with this issue. .

Maybe this link will help? http://www.informit.com/guides/content.aspx?g=windowsserver&seqNum=249
0
 
WSGAdministratorAuthor Commented:
I think I have narrowed it down to one of my CAS servers in my NLB.  When i disable CAS01 in the NLB, all the clients are conencting without problems.  When i enable CAS01 and disable CAS02, the error returns.  So the problem appears to be that my one CAS server is not configured correctly.  I have compared the IIS settings on each server and they seem to be identical.  Any suggestions on how to determine the difference in settings between the two servers?
0
 
badgermikeCommented:
I am not sure about the best way -

I found this post about 2 cas's: http://www.themssforum.com/ExchangeAdmin/Autodiscover/

0
 
badgermikeCommented:
also: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1662577&SiteID=17

If you haven't already looked at most of these links:)
0
 
badgermikeCommented:
in the above link there is another link in that that I just read that could be helpful something about needing ......leads me to believe this is a cert issue.

http://www.redline-software.com/eng/support/articles/msexchange/2007/load-balancing-exchange-2007-client-access-servers-windows-network-technology-part3.php
0
 
WSGAdministratorAuthor Commented:
Because I had the CAS servers in an NLB and one of the nodes was working properly for OOF and AutoDiscovery, i uninstalled Exchange 2007 from the faulting node and reinstalled.  This fixed the error as all the CAS settings for the fresh install were configured to match the existing settings on the working node.  Right now, OOF and AutoDiscovery is working for Outlook 2007 clients.  I dont know if this is an issue or not, but even though these features are working properly, when i run the test-outlookwebservices cmdlet, i am still recieving the same errors as I was before.  Any thoughts on why the errors would still show in this test but the functionality seems to be working properly?

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address Administrator@mydomain.com.

Id      : 1007
Type    : Information
Message : Testing server pfgcas01.ad.mydomain.com with the published name https://owa.mydomain.com/EWS/Exchange.asmx & https://owa.mydomain.com/EWS/Exchange.asmx.

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://owa.mydomain.com/autodiscover/autodiscover.xml.

Id      : 1013
Type    : Error
Message : When contacting https://owa.mydomain.com/autodiscover/autodiscover.xml received the error The remote server returned an error: (401) Unauthorized.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.
0
 
WSGAdministratorAuthor Commented:
As everything seems to be working, I'm not going to worry too much about it either.  Thanks for working with me on this.
0
 
badgermikeCommented:
sure thing. Glad everthing is working now
0
 
WSGAdministratorAuthor Commented:
Thanks for the help.  I sat around for almost 2 days having to revise the question several times before anyone would get back to me, so thanks for stepping up to bat.  If i hear anything about these errors even though everything seems to work, I'll let you know.

Thanks again,
Chris
0
 
badgermikeCommented:
Yeah please do because I'll probably need to get through it too.

Thanks!
Mike
0
 
jjozCommented:
Yes,

i also having the same issue ever since i install Exchange Server 2007 since February till now

the only thing that won't work properly are:

1. Out of office assistant (OOF) from Outlook 2007/2003 client.
2. Free/Busy time scheduling from Outlook client.
3. Offline address book download.

but all seems to be working just fine from OWA though.
I frequently update my Windows Server 2003 and Exchange all to the latest but still the problem exist.

here's my posting in another forum:
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3388640&SiteID=17&mode=1

hope that helps.
0
All Courses

From novice to tech pro — start learning today.