unable to browse internet

Pix is able to ping from the outside interface

how can i enable the pix to allow internet traffic.   i always thought it was open by default


johnkesoglouAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jojuezCommented:
No, by default it stops pretty much everything. You need to create a NAT rule that will allow all from inside out. Or you can scale it down to your specific ports.
0
johnkesoglouAuthor Commented:
what is the command line for it?
0
jojuezCommented:
Ok, you are going to need to setup an NAT translation and PAT as well, here is an example of how the command should look:

nat (INTERNALINTERFACENAME) 1 YourSubNet NetMask

and then this command:

global (OUTSIDEINTERFACE) 1 ExternalIP netmask NetMask

for my pretend network:

nat (inside) 1 172.16.10.0 255.255.255.0

global (outside) 1 66.22.44.55 netmask 255.212.202.2

All of the above commands have to be run from enable.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

jojuezCommented:
Also, if you are a beginner with PIX, it might not be too prudent for you to install the ASDM. Unless you are specifically trying to learn the commands. In that case, I recommend the Cisco press CCSP SNPA certification guide, tons of good info in there and the Cisco press ASA and PIX handbook.
0
johnkesoglouAuthor Commented:
ERROR: 65.39.65.130-65.39.65.130 overlaps with outside interface address
Command failed
0
jojuezCommented:
can you post your running config? do a sh run and copy and paste that. Make sure to remove or change any IP addresses so you arent posting that all over the web.
0
johnkesoglouAuthor Commented:

PIX Version 6.3(4)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password Iclsn9dz61Tm1Neg encrypted
passwd 7l/i4imp4C9g.ME2 encrypted
hostname NPIFW01
domain-name corp.falconig.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.2.0 255.255.255.0
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.3.0 255.255.255.0
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.4.0 255.255.255.0
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.5.0 255.255.255.0
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.6.0 255.255.255.0
access-list 118 permit ip 10.0.9.0 255.255.255.0 10.0.7.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.2.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.3.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.4.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.5.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.6.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.7.0 255.255.255.0
access-list nonat permit ip 10.0.9.0 255.255.255.0 10.0.10.0 255.255.255.0
access-list 119 permit ip 10.0.9.0 255.255.255.0 10.0.10.0 255.255.255.0
access-list outside_access_in permit tcp any host xxx.xxx.xxx.131 eq 3389
access-list outside_access_in permit tcp any host xxx.xxx.xxx.132 eq 3389
access-list outside_access_in permit tcp any host xxx.xxx.xxx.133 eq 3389
access-list outside_access_in permit tcp any host xxx.xxx.xxx.134 eq 3389
access-list outside_access_in permit tcp any host xxx.xxx.xxx.131 eq www
access-list outside_access_in permit tcp any host xxx.xxx.xxx.132 eq www
access-list outside_access_in permit tcp any host xxx.xxx.xxx.133 eq www
access-list outside_access_in permit tcp any host xxx.xxx.xxx.134 eq www
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.130 255.255.255.224
ip address inside 10.0.9.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 171.68.225.212 255.255.255.255 inside
pdm location 10.0.2.0 255.255.255.0 outside
pdm location 10.0.3.0 255.255.255.0 outside
pdm location 10.0.4.0 255.255.255.0 outside
pdm location 10.0.5.0 255.255.255.0 outside
pdm location 10.0.6.0 255.255.255.0 outside
pdm location 10.0.7.0 255.255.255.0 outside
pdm location 10.0.10.0 255.255.255.0 outside
pdm location xxx.xxx.xxx.130 255.255.255.255 inside
pdm location xxx.xxx.xxx.128 255.255.255.224 inside
pdm location xxx.xxx.xxx.128 255.255.255.255 outside
pdm location xxx.xxx.xxx.0 255.255.255.0 outside
pdm location xxx.xxx.xxx.0 255.255.0.0 outside
pdm location xxx.xxx.xxx.132 255.255.255.255 outside
pdm location 10.0.0.12 255.255.255.255 inside
pdm location 10.0.9.12 255.255.255.255 inside
pdm location 10.0.9.10 255.255.255.255 inside
pdm location 10.0.9.11 255.255.255.255 inside
pdm location 10.0.9.13 255.255.255.255 inside
pdm location xxx.xxx.xxx.72 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1 xxx.xxx.xxx.132
global (outside) 1 xxx.xxx.xxx.129 netmask 255.255.255.224
nat (outside) 1 xxx.xxx.xxx.128 255.255.255.224 0 0
nat (outside) 1 xxx.xxx.xxx.0 255.255.255.0 0 0
nat (outside) 0 0.0.0.0 0.0.0.0 outside 0 0
nat (inside) 0 access-list nonat
nat (inside) 1 10.0.9.0 255.255.255.0 0 0
static (inside,outside) tcp xxx.xxx.xxx.131 3389 10.0.9.10 3389 netmask 255.255.255
.255 0 0
static (inside,outside) tcp xxx.xxx.xxx.132 3389 10.0.9.11 3389 netmask 255.255.255
.255 0 0
static (inside,outside) tcp xxx.xxx.xxx.133 3389 10.0.9.12 3389 netmask 255.255.255
.255 0 0
static (inside,outside) tcp xxx.xxx.xxx.134 3389 10.0.9.13 3389 netmask 255.255.255
.255 0 0
static (inside,outside) tcp xxx.xxx.xxx.131 www 10.0.9.10 www netmask 255.255.255.2
55 0 0
static (inside,outside) tcp xxx.xxx.xxx.132 www 10.0.9.11 www netmask 255.255.255.2
55 0 0
static (inside,outside) tcp xxx.xxx.xxx.133 www 10.0.9.12 www netmask 255.255.255.2
55 0 0
static (inside,outside) tcp xxx.xxx.xxx.134 www 10.0.9.13 www netmask 255.255.255.2
55 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.129 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http 10.0.9.0 255.255.255.0 inside
snmp-server host outside xxx.xxx.xxx.72
no snmp-server location
no snmp-server contact
snmp-server community vinduvin
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map mymap 1 ipsec-isakmp
crypto map mymap 1 match address 118
crypto map mymap 1 set peer xxx.xxx.xxx.3
crypto map mymap 1 set transform-set myset
crypto map mymap 2 ipsec-isakmp
crypto map mymap 2 match address 119
crypto map mymap 2 set peer xxx.xxx.xxx.66
crypto map mymap 2 set transform-set myset
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address xxx.xxx.xxx.3 netmask 255.255.255.255 no-xauth
isakmp key ******** address xxx.xxx.xxx.66 netmask 255.255.255.255 no-xauth
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
isakmp policy 21 authentication pre-share
isakmp policy 21 encryption 3des
isakmp policy 21 hash md5
isakmp policy 21 group 2
isakmp policy 21 lifetime 86400
telnet xxx.xxx.xxx.130 255.255.255.255 outside
telnet 10.0.9.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 171.68.225.212 255.255.255.255 inside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 10.0.9.100-10.0.9.110 inside
dhcpd dns 207.7.4.66 10.0.2.20
dhcpd wins 10.0.2.20 10.0.2.21
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain xxxxxxx.com
dhcpd option 150 ip 10.0.7.20
dhcpd enable inside
terminal width 80
Cryptochecksum:ff463f2d1b45907ba52ad989d32d8243
: end
NPIFW01#

Open in new window

0
jojuezCommented:
In you configuration it looks as if you have access lists configured to allow specific ip addresses to gain access through the www. You can add one for your specific subnet and then anyone on that sub will have access.
0
johnkesoglouAuthor Commented:
thanks.......how do i do that :)
0
jojuezCommented:
access-list outside_access_in permit tcp any host 172.16.10.0 eq www

Leaving a zero at the end tells the firewall that the entire subnet is to be allowed rather than a specific ip.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnkesoglouAuthor Commented:
do i need to remove the other specific addresses?
0
johnkesoglouAuthor Commented:
also - still not working :(
0
jojuezCommented:
Weird for there to be so much in the config with this being a new device. I am lookin it up.
0
johnkesoglouAuthor Commented:
hi there - just following up to see fi there is any progress.
0
johnkesoglouAuthor Commented:
once the firewall was rebooted it worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.