How do I configure Public Folder access for OWA users when folders reside on separate servers (using SSL)

I have an Exchange 2003 server set up with Public Folders on two separate servers.  From within the company I can access all public folders and their contents using MS Outlook.  I need to get Public Folder's configured properly so my OWA users can access their information from outside the company's walls though.  This used to work until I required SSL at OWA login.  I can get to the Public Folders on the Exchange box that hosts the mailboxes, but on the other server where there is only Public Folders stored, I cannot access them using OWA.  I click on the folders and get a "this page can not be displayed" error message.  Any one know where I can begin troubleshooting this?
TimothyBoggessAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

isaman07Commented:
Have you enables SSL access on the other pubic folder server? What is the name registered in your SSL certificate? Did you install the certificate on the other server also?
Let me know.

Harout
0
TimothyBoggessAuthor Commented:
I have not enabled SSL on the other public folder server.  The name registered in the SSL certificate is mail.domainname.com so I didn't install a certificate on the other server.  I assumed if I didn't require SSL for the public folders it wouldn't be necessary?
0
isaman07Commented:
It depends on how you installed the certificate, if you installed it on the website level and since both OWA and Public folders are virtual directories within the same website, they will both require secure access.
You are able to access the public folders on the first server, cause the certificate is installed automatically on it, but your second server does not have a certificate.
To test this, check what is the URL when you try to access public folders on your second server does it start with HTTPS or HTTP?

Harout
0
TimothyBoggessAuthor Commented:
I checked to see if OWA was looking for a secure website and it was (https) so I installed a certificate on the second server, but it's still the same error.
0
TimothyBoggessAuthor Commented:
Not having found a reasonable answer I'm closing this question.  My resolution is to move all the public folders to the same server so they can be seen from OWA.  Seems like a poor solution, but it will take care of my problem for now and I can get back to work.  Thanks for the help.  Please refund my points since there wasn't an acceptable solution.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.