Not able to delete folder from solaris

We installed WAS61 BASE mistakenly instead of WAS61 ND and one of our administrator delete WAS61 BASE using rm -rf command instead of uninstall. Now the problem is that their is a folder in /opt called WebSphere61 that we are not able to delete and we tried to install BASE product again, but It won't give the permissions to install BASE as well as ND. The OS is Solaris 9. Wait for your early response. Thanks.
GurindersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

omarfaridCommented:
Why not being able to delete the folder WebSphere61? What command you used and what error you get?
0
TintinCommented:
Did the administrator try to remove the folder in /opt as the root user?
0
GurindersAuthor Commented:
I tried with "sudo rmdir WebSphere61" and also tried with rm -rf  WebSphere61. Yes, administrator also tried to remove but couldn't remove it.  He was telling that "you cannot delete it.  it's a mounted file system". Thanks for the quick response. Please help!
0
TintinCommented:
If it's a mounted filesystem, you need to do

rm -rf  /opt/WebSphere61/*
umount /opt/WebSphere61
rmdir /opt/WebSphere61

then remove the entry from /etc/vfstab
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GurindersAuthor Commented:
You answer is perfect. Unfortunately we cann't unmount the filesyste.. Its another department that take care of it.. But won't their be any way without unmounting the drive.. what is the route cause of this.. Is this happened because we didn't uninstall the software and remove using rm -rf command or this has to be like this even if we uninstall the same was61 Base.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.