?
Solved

cisco firewall upgrade

Posted on 2008-02-12
3
Medium Priority
?
269 Views
Last Modified: 2013-11-16
we have a cisco pix 501 firewall. I have the running config, and startup config saved to a file. We purchased cisco asa 5510 series

adaptive security appliance.

can I just copy the running and startup config into this appliance and plug it in?
0
Comment
Question by:zenworksb
  • 2
3 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 2000 total points
ID: 20879716
You can, but you will get errors since some of the command syntax has changed.  In some cases when you paste in the old command, the command will be automatically changed into the new syntax, but in other cases it will go in just fine with no changes or will give you an error with a hint as to the new syntax....it depends on the particular command.  Probably 60-70% of the commands will port over OK, but you will see errors on the others.
0
 

Author Comment

by:zenworksb
ID: 20915129
this is my startup config from teh startup config what shoudl I do differently

pixfirewall# sh start
: Saved
: Written by enable_15 at 13:39:12.200 UTC Mon Oct 15 2007
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password IuyQn3bTHJYCMcwZ encrypted
passwd s/qIQ/XeEv7OLVNv encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.169.1.0 Z-Private-Net
name 192.169.1.10 LINUX
name 192.169.1.2 Z2
name 192.169.75.0 PrivNet
name 192.198.1.4 z3
name 64.18.0.0 Postini
object-group service Groupwise tcp
  port-object range 1677 1677
  port-object eq www
object-group service TerminalServices tcp
  port-object range 3389 3389
access-list inside_access_in permit ip Z-Private-Net 255.255.255.0 any
access-list inside_access_in permit icmp Z-Private-Net 255.255.255.0 any
access-list inside_access_in permit tcp any any
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit tcp any interface outside object-group Grou
pwise
access-list outside_access_in permit tcp Postini 255.255.240.0 interface outside
 eq smtp
access-list inside_outbound_nat0_acl permit ip Z-Private-Net 255.255.255.0 PrivNet 255.255.255.0
access-list inside_outbound_nat0_acl permit ip Z-Private-Net 255.255.255.0 19
2.168.110.0 255.255.255.192
access-list inside_outbound_nat0_acl permit ip Z-Private-Net 255.255.255.0 19
2.168.1.0 255.255.255.129
access-list outside_cryptomap_20 permit ip Z-Private-Net 255.255.255.0 PrivNet 255.255.255.0
access-list ZVPN_splitTunnelAcl permit ip Z-Private-Net 255.255.255.0 any
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.0 255.255.255.192

access-list N_splitTunnelAcl permit ip Z-Private-Net 255.255.255.0 an
y
access-list outside_cryptomap_dyn_40 permit ip any 192.168.1.0 255.255.255.128

pager lines 24
logging on
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 2.4.1.2 255.255.255.252
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ZPOOL 192.168.1.1-192.168.1.50
ip local pool npool 192.168.1.51-192.168.1.100
pdm location Z-Private-Net 255.255.255.0 inside
pdm location Z2 255.255.255.255 inside
pdm location LINUX 255.255.255.255 inside
pdm location 6.2.5.2 255.255.255.248 outside
pdm location PrivNet 255.255.255.0 outside
pdm location z3 255.255.255.255 inside
pdm location 6.1.3.1 255.255.255.255 inside
pdm location Postini 255.255.240.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www z3 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp z3 smtp netmask 255.255.255.255 0
0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 6.6.3.5 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 6.2.5.200 255.255.255.248 outside
http Z-Private-Net 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 0
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 66.122.65.202
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 6.1.6.2 netmask 255.255.255.255 no-xauth no-co
nfig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup ZVPN address-pool ZACAPOOL
vpngroup ZVPN split-tunnel ZACAVPN_splitTunnelAcl
vpngroup ZVPN idle-time 1800
vpngroup ZVPN password ********
vpngroup N address-pool novacoastpool
vpngroup N split-tunnel NOVACOAST_splitTunnelAcl
vpngroup N idle-time 1800
vpngroup N password ********
telnet Z-Private-Net 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:084f4d6b24e33f5807b39ac6a59c1478
pixfirewall#
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20915207
Since your ASA is non-production until you get the config ported over, I would go ahead and paste the entire config in as is and then post what you wind up with and I can help from there, comparing that configuration with the one you just posted.

In a nutshell, the fixup commands will be converted into inspect statements automatically, your ACL's will port over with no changes, as well as your crypto commands, statics, nats and global commands.  Your isakmp commands will need to be tweaked since they are now implemented via "crypto isakmp" and "tunnel-group" commands and have a little different syntax about the different parameters.  Also, your vpngroup commands are now implemented via "group-policy" commands.

Anyway, post the config after you paste it in and we'll go from there.
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…

592 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question