How do I Create a user which has access to all files regardless of Permission on files

I am in a situation where files get copied to a Solaris network drive and the GROUP permissions get cleared. I'm not quite sure why, but I need to create a user that can then access these files regardless of any file permissions. (Like ROOT would be able to do)

Then I can map the drives in Windows and MACOS using this user.

Thanks
-Roger
LVL 1
cadancecorpAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
a) If you do not want to use RBAC, you will have to add a user with UID = 0
    Caution: This will make this user account identical to the root user!
b) Using RBAC, you will provide the user with a role allowing to read (and
    write?) all files. Predefined roles can be found in /etc/security/prof_attr
    The following files are the databases fir RBAC:
    - /etc/user_attr (main RBAC file)
    - /etc/security/prof_attr (right profile attributes/authorizations)
    - /etc/security/exec_attr (profile execution attributes)
    - /etc/security/auth_attr (authorization attributes).
    To learn more about RBAC, look at
    http://www.sun.com/software/whitepapers/wp-rbac/wp-rbac.pdf (White Paper)
    http://www.sun.com/bigadmin/content/submitted/custom_roles_rbac.html (custom examples)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Maybe, you should better try to find out why the group permissions are take away:
Are you using SaMBa? Which version?
If using SaMBa, could you please post smb.conf with (at least) the entry for the
share you use?
What are the permissions for the directory itself with this share?
0
cadancecorpAuthor Commented:
No, Its Appletalk.. When people copy from the MAC to the Solaris the Group Permissions go away. When users copy from a  windows workstation the SMB.CONF takes care of the permissions. 077.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Try changing the directory's permission setting the GUID bit:
   chmod g+s  directory
0
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Type: I mean "set-group-ID" bit
0
cadancecorpAuthor Commented:
Hi, we are not too worried about security so I will set the user to UID=0
0
Hanno P.S.IT Consultant and Infrastructure ArchitectCommented:
Have you tried to fix your problem changing the (parent) directory's permissions
  # chmod 750 mydir  
  # chmod g+s mydir
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.