Disabling Wall Paper Through Group Policy

How can I prevent a student from right clicking on a picture they downloaded and selecting "set as desktop wallpaper" through group policy?  The display properties is already disabled by right clicking the desktop so they cannot change wallpaper this way.  Please help.
LVL 3
beaconlightboyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dooleydogCommented:
I think this will help.

For Windows XP Professional Edition:

---------------

1. Click Start and then Run. Type "gpedit.msc" without quotes and press Enter.

2. In Group Policy Editor, go to

 

Local Computer Policy -> User Configuration -> Administrative Templates -> Control Panel -> Display

 

3. Locate a setting named "Prevent Changing Wallpaper". Double click to open it.

4. Select  Enable and click OK.

 

 

For Windows XP Home Edition

---------------

1. Click Start and then Run. Type "regedit" without quotes and press Enter.

2. Navigate to the following branch:

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

 

3. Please check if there is the value: NoChangingWallPaper. If so, please double click it and then change its value to 1

 

Note: If the value name doesnt exist, we need to create it manually (Right click the blank space and choose New -> DWORD value)

 

For your reference, you can also copy the following content to a Text Document, and then save it as an Reg file (such as NoChangingWallPaper.reg). Then we can double click the  reg file to import the content to registry:

 

Windows Registry Editor Version 5.00

 

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop]

"NoChangingWallPaper"=dword:00000001

Good Luck,

dooleydogCommented:
also in group policy,

Local Computer Policy -> User Configuration -> Administrative Templates -> Desktop -> Active Desktop: 'Active Desktop Wallpaper'

and select your own background.

Good Luck,

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.